Windows 1709 - Storage of ino files on OneDrive

Hello,

I’ve been using a OneDrive folder as my Arduino Sketch folder to always work on the latest ino files from my PC or my laptop. This worked fine until the latest WIndows 1709 upgrade that brought new OneDrive functionality.

Even after I set my OneDrive sketch folder to “always sync” I cannot compile my old (or new) sketches. Funny enough I can browse sketches with the Arduino IDE - load em without error messages.

Compiling yields an error “readlink \folderstructure\project\project.ino: The system cannot find the file”

Any practical workaround?
Will this work in a future version of the IDE (that would be great since using OneDrive for sketches is so convenient for me)

Thanks for your input!

BeeJayF

The relevant issue tracker report:

Thanks!

If this is a solution, can you please provide step-by-step instructions for implementing it?

Thanks
Karl

  • Move the sketch files out of your OneDrive folder
  • If your sketchbook was previously set to the OneDrive folder then update File > Preferences > Sketchbook location accordingly.
  • If you have a GitHub account then subscribe to Creators update: >Compile errors after document folder moved to \onedrive\ subfolder · Issue #6867 · arduino/Arduino · GitHub. That issue report will be closed when the problem is resolved and you will get a notification of it. Otherwise, make sure you get notifications from this thread and hope we remember to also comment here.
  • If the Arduino IDE has been modified to fix the issue then soon after you can use the hourly build or beta build of the Arduino IDE to immediately access the fix and be able to go back to using OneDrive with the Arduino IDE, or you can wait for the next official release of the IDE.

I had the same problem with onedrive after the fall creator update. Just un-check "Files On-Demand" in onedrive setting, arduino IDE can normally read and compile sketch. In my case, it works.

Worked for me too

danghoanganh:
I had the same problem with onedrive after the fall creator update. Just un-check "Files On-Demand" in onedrive setting, arduino IDE can normally read and compile sketch. In my case, it works.

It worked fine to me.

Unchecking 'Files on Demand' worked for me also. Many thanks.