Windows 7 and driver signing

Hi all,

I am starting to lose the plot on this one. I've got an Uno R3 and a Mega 2560 R3, and both are exhibiting the same problem: I cannot get Windows 7 (64 bit) to install the drivers. I know that the Arduinos are OK because I can access them using a Linux VM on the same Windows 7 machine, but the Windows machine itself won't connect to them.

I've tried all of the tips I can find online, I've turned off driver signing, everything I can think of, and it just will not work. The Arduino will be communicating with a .NET program on the PC, so I really need to get it working!

Any suggestions gratefully received while I still have some hair left! TIA.

look in device manager and search for the Arduino, this should be a question mark - unknown device
right click -> install driver manually.

worked for me on windows 8, 64bit

Thanks for the suggestion, but I’ve manually re-installed the drivers many times without success. It gets right through the install procedure, asks if I want to install an unsigned driver, I click OK, then when it completes it brings up a message saying that it couldn’t install the driver because it wasn’t signed.

Try this

solution #2
if this doesn't work, I think I cannot help you, sorry.

solution #3
Try: Arduino Forum :smiley: it's automated, so if it still does not work, there is something bad with the system files / board

Thanks eried and karlok. I've tried installing the enhanced IDE (solution 3) but it still says that there is a problem with installing the drivers because they are unsigned.

I admit I'm a bit reluctant to try 2 because the driver is a built-in Windows USB driver and I don't want to risk messing up my work PC!

OK, I can now get the driver to install if I disable Driver Signing Enforcement on boot-up :slight_smile: but it's broken again if I reboot normally.

Is there a way of making that driver install permanent? I don't want to have to press F8 and get into the boot menu every time I start Windows.

That's weird, win 7 x64 should allow unsigned drivers with a warning. Can you try to find a setting for that behavior? like "allow unsigned drivers" but not that boot option, something in the control panel/PC properties.

My installer does not messes with anything, I don't like that too, the only thing I modify is the program files directory + PATH (but it is cleaned upon uninstallation)

That setting is not there by default in Windows 7 64-bit, I had to go into Windows\inf\sceregvl.inf and add stuff to enable it, but that doesn't make any difference. I am currently trying to change the group policy to ignore unsigned driver errors.

When I had win7 x64, if I allowed unsigned drivers I got this dialog: http://usbdm.sourceforge.net/USBDM_V4.9/USBDM_JMxx/html/UpdateDriverSoftware3.png so the option is somewhere in the Control panel. In win8 there is no option so I can't say where it is, maybe in the action center? or type "unsigned" in the search

I get that dialog too, and I click on "Install anyway", but when it gets to the end of the install it comes up with a box saying that it failed to install because the driver wasn't signed!

It's all very strange...

I think they should do a sticky on this.

Is there something unique about this Windows 7 install that you haven't mentioned?
Is this a "corporate" image or something like that, with a group policy set to restrict unsigned drivers?

A standard install of Win7 x64 does not have this issue, other than the warning during the first install.
I use it on Win7 x64 all the time without the problem you describe.

The problem you describe, seems to indicate there is a policy setting that is enforcing this behavior.

i have had this when not signed in as administrator ,i guess you tried that?

It doesn't work as administrator, and I'm using a standard Windows 7 install.

Could removing SP1 from Windows 7 be the cause of the problem? I had to take it off as it broke ADO compatibility with desktop programs I develop.

A "standard Windows 7 install" doesn't say anything about other (network) policies that may be installed. You had mentioned earlier in the tread that this is a work computer. If there are group policies in place (something that many offices will implement on their machines), than more than likely that's the culprit. A stand-alone, no policies, non-cripled, no bacon, no ice-cream Windows 7 install will allow unsigned drivers to be installed after approving the warning pop up. To me it seems you have a policy installed that's preventing that from happening, regardless of you approving the pop up message.

Our network policy doesn't have anything defined under "Devices: Unsigned driver installation behaviour". Should it?

I've had to resort to running both the Arduino IDE and Visual Studio in a VMware XP virtual machine in order to be able to access my Uno and Mega on this Windows 7 64-bit machine. :sigh:

Had the same problem in Win 8, went back to my old XP laptop, works fine there.

This is how to install Arduino drivers in Windows 8:
http://www.bryonconnolly.com/windows-8-arduino-driver-install
It got me trouble and for a while I'd use VMWare.
EDIT this is a better guide.
http://www.windows7hacker.com/index.php/2012/08/how-to-install-an-un-signed-3rd-party-driver-in-windows-8/