Windows 7 can't find drivers

Hello,
I have an Arduino Mega 2560 and Windows 7, but I’m having troubles installing the drivers.
After sone researchs, I downloaded the VCP drivers here http://www.ftdichip.com/Drivers/VCP.htm, but when I go to the Device manager to update the Arduino drivers (Device Manager → Other devices → Right Click on “Arduino Mega 2650” → Update Driver Software → Browse Manually → …), Windows can’t find the drivers.
I re-downloaded the drivers, checked the path, …

Thanks in advance.

but when I go to the Device manager to update the Arduino drivers (Device Manager -> Other devices -> Right Click on "Arduino Mega 2650" -> Update Driver Software -> Browse Manually -> ...), Windows can't find the drivers.

The ... in that string implies that another dialog box is to be posted, which you use to locate a folder containing the drivers. If you do not navigate to a folder that contains the drivers, of course Windows can't find the files there.

So, what folder did you navigate to? What files are actually in that folder?

Timbuk, if you get install arduino´s driver, send me a mail, i have a Arduino uno + Win 7 and i can´t install the drivers. :slight_smile:

Thank

The Mega 2560 and Uno don't use the FTDI drivers. Instead, they use built-in Windows drivers, but you need to point Windows to a .inf file that describes the board. These are located in the drivers/ directory of the Arduino software (not the FTDI USB Drivers/ sub-folder of it).

Thanks!, that was exactly my problem, I was pointing Windows to the FTDI USB Drivers/ folder.