Windows 8.1 USB 2.0/3.0 Boots but doesn't Communicate

The IDE fails when uploading the EsploraBlink program on USB 2.0 or USB 3.0 ports on Windows 8.1.

Basics

  • Arduino Esplora (purchased December 2013)
  • Arduino IDE 1.0.5 (downloaded 30 December 2013)
  • Arduino EsploraBlink Program
  • Arduino supplied USB cable
  • Successfully configured the Windows 8.1 USB port drivers per Arduino instructions
  • HP Pavilion Desktop (AMD processor)

Esplora

  • Steady "ON" LED
  • "L" LED flashes when USB is plugged in and when the IDE upload starts
  • "TX" and "RX" LEDs flash when the upload starts
  • "RX" but no "TX" activity after "L" stops flashing
  • Steady "TX" but no "RX" activity when I open the Serial Monitor

IDE

  • Shows Arduino Esplora on COM4 in bottom right corner (correct)
  • Programmer: USBasp
  • No compiler errors
  • Upload times out with "buffered memory access not supported."
Found programmer: Id = "B°U"; type =
Software Version = . ; Hardware Version =  .
Avrddude: error: buffered memory access not supported. Maybe it  isn't a butterfly/AVR109 but a AVR910 device?

Troubleshooting

Working from Forum posts I correctly installed the USB drivers and changed Programmer from the default AVRISP mkII to USBasp (no improvement). I also tried holding the Esplora RESET button down through the compile process and releasing it when the Upload process begins (no improvement).

I opened the Serial Monitor window. The Esplora TX LED came on steadily and the monitor window started scrolling steadily (blank lines). It was set to 9600 Baud COM4 (correct). I tried all four combinations of NL/CR handling without success.

What next?

"Programmer" only comes into play when an AVR ISP is connected to the ICSP header. What your attempt describes - with "Arduino supplied USB cable" - sounds more like a Serial Upload (or fron the menu, File:Upload).

I haven't used Esplora yet and returned a Win8 laptop, sorry can't offer more.

Windows 7 Installation Succeeded

I gave up on Windows 8.1 and was successful on Windows 7.