Windows could not find drivers for your device

Hi everyone, first time in Arduino world, and I'm having trouble with driver installation.
I've tried going to device manager > update driver> manually browse driver's folder location, but it keeps saying "windows could not find drivers for your device"
I've tried reinstalling IDE,, reinstall with previous version of 1.8.14, 1.8.13, 1.0.6,, installing from microsoft store vs zip package vs exe. files, and reseting the arduino uno but none works. Right now the board has ON led turned on, and slow blinking of L led, resetting turns the L led to blinking twice fast, so I'm assuming the board has no problem?

Could you take a few moments to Learn and Use The Forum

Welcome to the Arduino Forum. This guide explains how to get the best out of this forum. Please read and follow the instructions below. Being new here you might think this is having rules for the sake of rules, but that is not the case. If you don’t follow the guidelines all that happens is there is a long exchange of posts while we try to get you to tell us what we need in order to help you, which is frustrating for you and frustrating for us.

It will help you get the best out of the forum in the future.

  • Your OS and version can be valuable information, please include it along with extra security you are using.

  • Always list the version of the IDE you are using and the board version if applicable.

  • Use quote or add error messages as an attachment NOT a picture.

  • How to insert an image into your post. ( Thanks @sterretje )

  • Add your sketch where applicable but please use CODE TAGS ( </> )

  • Add a SCHEMATIC were needed even if it is hand drawn

  • Add working links to any specific hardware as needed (NOT links to similar items)

  • Remember that the people trying to help cannot see your problem so give as much information as you can

COMMON ISSUES

  • Ensure you have FULLY inserted the USB cables.

  • Check you have a COMMON GROUND where required. ( Thanks @Perry)

  • Where possible use USB 2.0 ports or a USB 2.0 POWERED HUB to rule out USB 3.0 issues.

  • Try other computers where possible.

  • Try other USB leads where possible.

  • You may not have the correct driver installed. CH340/341 or CP2102 or FT232 VCP Drivers - FTDI

  • There may be a problem with the board check or remove your wiring first.

  • Remove any items connected to pins 0 and 1.

COMPUTER RELATED

  • Close any other serial programs before opening the IDE.

  • Ensure you turn off any additional security / antivirus just to test.

  • There may be a problem with the PC try RESTARTING it.

  • You may be selecting the wrong COM port.

  • Avoid cloud/network based installations where possible OR ensure your Network/Cloud software is RUNNING.

  • Clear your browsers CACHE.

  • Close the IDE before using any other serial programs.

  • Preferably install IDE’s as ADMINISTRATOR or your OS equivalent

ARDUINO SPECIFIC BOARDS

  • CH340/341 based clones do not report useful information to the “get board info” button.

  • NANO (Old Types) some require you to use the OLD BOOTLOADER option.

  • NANO (ALL Types) See the specific sections lower in the forum.

  • NANO (NEW Types) Install your board CORE’s.

  • Unless using EXTERNAL PROGRAMMERS please leave the IDE selection at default “AVRISP mkII”.

  • Boards using a MICRO usb connector need a cable that is both DATA and CHARGE. Many are CHARGE ONLY.

CREATE editor install locations.

  • On macOs ~/Applications/ArduinoCreateAgent-1.1/ArduinoCreateAgent.app/Contents/MacOS/config.ini

  • On Linux ~/ArduinoCreateAgent-1.1/config.ini

  • On Windows C:\Users[your user]\AppData\Roaming\ArduinoCreateAgent-1.1

Performing the above actions may help resolve your problem without further help.

Language problem ?

Try a language closer to your native language:

Thanks to all those who helped and added to this list.

Chances are you are using a CLONE which may need extra drivers not available with the IDE.
Include a decent picture of the area near the USB connector.

What hardware IDs are shown in device properties?

Hardware ID's are not always a good clue.

VID and PID are :wink:

Considering that all we know about the board is "arduino uno", it would be better to check these. There are tons of clones with different chips for the USB part.

I'm not sure what you guys mean by VID and PID haha, does the image help?

Greatly.

Its a CH340 chip so you need the correct drivers which are linked here.

Not everybody knows how or what those are so we tend to get better results from pictures as is seen above.

There were also some oddball PIV VID's a long time ago too about the time of the FTDIGATE.

VID and PID stand for VendorID and ProductID and relate to the USB standard. In Windows you can find them in device manager as shown below

I couldn't open the link, but I googled CH340 driver and it worked!!!!! thank you everyone!!!! Expecially @ballscrewbob, you're my hero!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.