Windows/Linux/Mac Eclipse plugin to compile and upload arduino sketches

Start small. Don't take to big steps. Freecks documentation is what you need but get simple things working first.

Yes, of course ... starting small is good, but I would prefer at least to be starting in the right direction and not have to abandon and start again.

So my understanding is that yes, it is possible to debug the ESP32 using Sloeber. With a JTAG interface and the current release of Sloeber, Freeck's instructions should work. The instructions are these:

https://onedrive.live.com/view.aspx?resid=4EF34D0924CECD08!105684&ithint=file%2cdocx&app=Word&authkey=!ACWnebcSvI14a0w

and this:

https://www.youtube.com/watch?v=hxOB7Qp0yM0&feature=youtu.be

and this:

http://esp-idf.readthedocs.io/en/latest/api-guides/jtag-debugging/tips-and-quirks.html

Do you know if anyone other than Freeck has tried this and if so what their experience has been?

Do you know if the ESP Wrover Kit can be used instead of a standalone JTAG-ICE?

And, finally, in case of problems, do you know if Freeck can be contacted for help?

Many thanks

Robert

Would it be possible to add the ESP Exception Decoder to the Eclipse Arduino plugin, in the same way as on the Arduino IDE? https://github.com/me-no-dev/EspExceptionDecoder

This would be a very useful addition ... not as good as JTAG debugging, but very useful all the same.

RA5040: Would it be possible to add the ESP Exception Decoder to the Eclipse Arduino plugin, in the same way as on the Arduino IDE? https://github.com/me-no-dev/EspExceptionDecoder

This would be a very useful addition ... not as good as JTAG debugging, but very useful all the same.

You’ve seen post #1038 ?

6v6gt: You’ve seen post #1038 ?

Yes ... but all I can see is that it's on the list of things to do. I can't see where or how EspExceptionDecoder can be added to the plugin.

When I build the ESP32_BLE_Arduino example BLE Server, I get an error in the BLEClient.cpp library source file.

The error is "Invalid conversion from 'int' to 'esp_ble-address-type_t' [-fpermissive]"

The same code compiles fine on the Arduino IDE, so I guess this must be a compiler setting on the Eclipse-Arduino.

Help please!

Robert

[HELP]

Hi,

I used a core need to use [arm-none-eabi-gcc][5.4.0-2016q2], The default version of Sloeber is [4.8.3-2014q1] Now every time I use that core, I need to replace all the [4.8.3-2014q1] with [5.4.0-2016q2] manually.

I'm wondering if there is a setting or way to set the [arm-none-eabi-gcc][5.4.0-2016q2] automatically?

I'm getting an error on the subdir.mk file when building a test sketch for an Arduino Nano. The error is: cc1.exe: error: -fno-fat-lto-objects are supported only with linker plugin.

Here is the complete line from the console:

"C:\cpp-photon\eclipse\/arduinoPlugin/packages/arduino/tools/avr-gcc/4.8.1-arduino2/bin/avr-gcc" -c -g -Os -Wall -Wextra -std=gnu11 -ffunction-sections -fdata-sections -flto -fno-fat-lto-objects -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10802 -DARDUINO_AVR_NANO -DARDUINO_ARCH_AVR -I"C:\Users\Robert\Arduino\hardware\arduino\avr\cores\arduino" -I"C:\Users\Robert\Arduino\hardware\arduino\avr\variants\eightanaloginputs" -MMD -MP -MF"core\core\WInterrupts.c.d" -MT"core\core\WInterrupts.c.o" -D_IN_ECLIPSE_=1 "C:\Users\Robert\Arduino\hardware\arduino\avr\cores\arduino\WInterrupts.c" -o "core\core\WInterrupts.c.o" cc1.exe: error: -fno-fat-lto-objects are supported only with linker plugin. core\core\subdir.mk:182: recipe for target 'core\core\WInterrupts.c.o' failed make: *** [core\core\WInterrupts.c.o] Error 1

I don't know what the 'linker plugin' is ... or what I should do to fix this problem.

Well, I changed the platform to

C:\cpp-photon\eclipse\arduinoPlugin\packages\arduino\hardware\avr\1.6.2

I had another platform directory which obviously had missing elements.

Hello,

i just installed eclipse photon with the sloeber and i am trying to use some of my custom libraries but it doesn't seem that it can find them. I saw the directory that it uses to search for the libraries arduino/preferences and it is where i have placed my libraries. I saw another post with the same problem and i want to ask if with the 4.3 version this problem is going to change. I installed sloeber from Eclipse Marketplace, is it the 4.3 version or do i have to install the github that jantje uploaded recently? Also i want to use eclipse with teensy 3.6, any updates about the way i can achieve that, i' ve read the trippy lighting tutorial but it is for really old version of the software.

Thank you very much

For teensy just add [teensyduino]/hardware/teensy to the private hardware you probably also want to add [teensyduino]/libraries to your private libraries Private libraries can be the parent or the root of the library. If the private library folder you provide contains a .h file it is considered a library, else it is consider the parent of libraries. As far as I remember there are no known bugs in this area. Best regards Jantje

Hello again and thank you for your response, i have added teensy in the private hardware path and also i have added the directory of my libraries to the private software path. All the libraries contain the header files but when i try to add a library to the selected project, the list is empty and now i get a " Unhandled event loop exception" error. Also teensy board has not be added to the "platform and board" menu.

Thank you

Hi Jantje,

I installed the Eclipse Pluin on Mac (Eclipse Photon). I added the hardware platform "Adafruit/hardware/samd/1.2.1" and want to use "Adafruit Metro M4 (SAMD51)" board.

I could select the board in the properties menu of the project. If I verify the sketch, there is the following error:

/Users/walter.prechtl/eclipse/cpp-latest-released/Eclipse.app/Contents/Eclipse/arduinoPlugin/packages/adafruit/hardware/samd/1.2.1/cores/arduino/Arduino.h:48:17: fatal error: sam.h: No such file or directory

include "sam.h"

Do you know, how to install and include "sam.h"?

It should work. I can't tell based on the info you provided what could be the root cause. However eclipse provides all the tools and openness to find out yourself. Things to check Are you running Sloeber V4.3? Does this also happen with a new default sketch? Does the indexer find the sam.h file Is the package correctly installed? Is the package dependent on another package? And if so is that one properly? installed

Just thanks for your very good work, it's very more easy to use than the standard arduino editor

Firstly, love this plugin! I've got a bit of a weird situation though... I've got a sketch to run on an Atmega2560. Everything compiles, everything works, but in the code window Serial1 is underlined red and flagged Symbol 'Serial1' could not be resolved. But when I compile I get 0 errors, 0 warnings, and like I said everything works, but the error flag in the code remains. It's not actually causing an issue, but the red marks feel like they are mocking me!

@pinja read the troubleshouting faq http://eclipse.baeyens.it/faq.shtml#/troubleshooting Jantje

That sorted it out. Thanks!

I'm trying to compile the basicOTA.ino sample with Sloeber 4.3 for the esp32 but keep getting error's. It's totally not clear to me what's wrong. For the esp8266 it works fine and the other (the one i tried) esp32 samples didn't gave me troubles. I tried a lot of suggestions that where found on Github and google but nothing helped me.

|500x113

This is the list of the known issues. https://github.com/Sloeber/arduino-eclipse-plugin/issues?utf8=%E2%9C%93&q=label%3A%22status%3A+known+limitation%22+ I guess you are experiencing https://github.com/Sloeber/arduino-eclipse-plugin/issues/1028 A workaround is described in the issue