Windows looking for Servo drivers when connecting arduino via USB!


I have this weird problem with a couple of continuous servos I bought from Sparkfun the other day (

The problem is that when I in certain situations connect the arduino via USB to my computer, Windows 7 starts looking for servo drivers! It doesn't find any, so it keeps searching, then disconnects, searches again, disconnects, and so on with a steady interval of a few seconds. Basically this makes the servos completely useless, as I cannot control them what so ever.

I have experienced this problem in two situations:

  1. If I try to have both servos connected in parallel, using the same input pin.

  2. If I try to change the servos pin values.

In order to calibrate the servos - and change the speed in general - I need the servos to take a variable input value. But it appears that every time I change the input value, the servo(s) disconnect, and Windows starts looking for drivers. The setup I have been using to provoke this problem is a simple potentiometer with values mapped to 1000-2000 microseconds, values which are directly written to the servo(s). I can confirm that the potentiometer values are in place, and that they are getting written to the servo(s), by the serial monitor.

This is a vital part of my project, and I really have no idea of where to start debugging this phenomenon.. So thanks for helping me out!


Windows 7 starts looking for servo drivers

Servo drivers? Did you mean to write "[u]serial[/u] drivers"?

Frankly I have no idea! It might be the serial drivers for all I know. But I have been using the serial monitor before, and this is the first time I have encountered a problem like this. But if it is the serial drivers, is there something I can do about it?

Also I have to add: I just tried adding a LED to the serial output controlling the servos, and it appears it gives a slight blink every time the servos "connects"/"disconnects" in Windows. Could there be a software issue with the arduino?

How are you powering your servos? They generally cannot be powered from the arduino if that is what you have done.

I have been using the 5V from the arduino so far, so if the servos requires more juice than that it could probably be causing some problems. I don't have any external power source except the USB at the moment, but I'll try and find a way.


I have now tried using an external power supply (being 4 AA connected in serie, giving 6 volts total). The servo reacts for a millisecond, then shuts down, giving no sign what so ever. The control signal value doesn't matter, and the only way to get it move again, is to reconnect the battery.

Does anyone know how to deal with this? I am seriously considering to cut them open and control the motors manually very, very soon!

And thanks for the feedback. ;)


did you connect the negative side of the AA batteries to your ground?

No, but you're right.. The voltage would be floating otherwise.


no problem, a lot of people make that mistake. good luck with your project!