Windows no reconoce Arduino pero funciona el programa

Hola gente del foro...

Hace aproximadamente un mes que tengo un arduino nano v3.0, el cual programe muchas veces sin ningun problema, pero de repente windows no muestra el COM3 ni hace el sonido que indica que se conecto algun dispositivo usb. Actualice el controlador por las dudas pero sin ninguna respuesta favorable...

Lo raro de todo esto es que el ultimo programa que cargue en el Arduino sigue funcionando perfecto por lo cual supongo que no esta muerta la placa...

Que me recomiendan hacer??

Muchas gracias

una prueba cruzada

prueba ese arduino en otro ordenador y otro arduino en ese ordenador

Si ves que es el arduino es posible que se haya estropeado solo parte conversadora de serie a USB, podrías cambiar el chip, te costara unos pocos centimos

Sino tira el arduino y compra otro chino, te costara unos tres euros (mejor compra 2 o tres jaja)

Hola GO_zalo, gracias por responder.

Realice la prueba con los arduinos nano y el problema esta en la placa.

Dispongo de 3 arduinos nano pero al ya tener esta placa soldada a los componentes externos quisiera intentar rescarla, en el caso que no se pueda, cambio de arduino.

Te pregunto por si sabes... Al cambiar el integrado serie - usb, debo cargarle algun tipo de programa? O no es programable y cumple su funcion?

Gracias

Tball:
Hola GO_zalo, gracias por responder.

Realice la prueba con los arduinos nano y el problema esta en la placa.

Dispongo de 3 arduinos nano pero al ya tener esta placa soldada a los componentes externos quisiera intentar rescarla, en el caso que no se pueda, cambio de arduino.

Te pregunto por si sabes… Al cambiar el integrado serie - usb, debo cargarle algun tipo de programa? O no es programable y cumple su funcion?

Gracias

No es programable puedes quitarlo de otro arduino que sea igual, y es menos faena (si tienes un soldador de aire) que desmoldar todas las patas

Tampoco es garantía que funcione

Gracias por la ayuda pero no consegui el integrado en ninguna casa de electronica. Voy a optar por cambiar de arduino

Antes de dar por muerto el arduino probe alimentando el arduino desde Vin y la luz de pwr se mantienen constante mientras que L oscila entre encendido y apagado pero si cambio a usb la unica que se mantiene es PWR.

Habra alguna forma de eliminar la almientacion USB, alimentarlo desde Vin y de mientras poder programar conectado al usb?

ami ya me paso esto y yo lo solucione asi:

1.carga el programa BLINK 2. selecciona arduino nano 3. el puerto COM NO APARECERA pero lo dejas asi en blanco 4. click en "SUBIR"

****************** ESTE PASO ES EL BUENO****************** * 5. UN SEGUNDO DESPUES QUE LA BARRA CAMBIE DE COMPILANDO A SUBIENDO PICAS RÁPIDO EL BOTÓN "RESET" DEL ARDUINO. *


  1. el led del arduino comenzara a destellar

NOTA: tienes que intentar varias veces no sale ala primera PERO si vas en el intento numero 500 y no responde ahora informas de nuevo en el tema para ver que mas puedo opinarte

robertiko07, gracias por responder. Disculpa la demora en responder.

Realice repetitivamente la prueba que recomendas hacer sin buenos resultados. Automaticamente al cambiar de compliar a subiendo muestra el error:

Arduino:1.6.6 Hourly Build 2015/10/08 05:43 (Windows 7), Placa:"Arduino Nano, ATmega328"

El Sketch usa 1.030 bytes (3%) del espacio de almacenamiento de programa. El máximo es 30.720 bytes. Las variables Globales usan 9 bytes (0%) de la memoria dinámica, dejando 2.039 bytes para las variables locales. El máximo es 2.048 bytes. avrdude: ser_open(): can't open device "\.\COM3": El sistema no puede encontrar el archivo especificado.

Problema subiendo a la placa. Visita http://www.arduino.cc/en/Guide/Troubleshooting#upload para sugerencias.

Este informe podría tener más información con "Mostrar salida detallada durante la compilación" activala desde Archivo > Preferencias

que se refiere a que no hay nada conectado a los puertos... Hay algo que este haciendo mal? recomendas otra cosa?

listo ya esta... yo tenia el mismo problema y no sabia que pex... entre a varios foros pero sin la respuesta... a mi me aparecia especificamente este mensaje cada que intentaba subir algo: "can't open device "\.\COM3": El sistema no puede encontrar el archivo especificado" bueno pues el problema esta en los drivers

la solución que a mi me funcionó fue la siguente:

Primero te vas a la carpeta donde se instaló el software de arduino, y abres la carpeta de drives; ahi viene un archivo rar con el nombre old arduino drivers, esa la extraes y es importante que recuerdes en donde lo haces, en mi caso la deje en la misma carpeta de "drives"

en caso de que no la tenga (que lo dudo) les dejo el enlace para descargarlo: https://mega.nz/#!T9By0QCQ!jZuhtaz_LEqzTNDpQIprh0u__Kz6iIMLdOO-7bGXO9c

Despues abres el administrador de dispositivos en windows (mi windows es W7, pero si no mal recuerdo es casi lo mismo en todos). Ya sabes te vas a INICIO-(CLICK DERECHO EN)EQUIPO-PROPIEDADES

O simplemente en el buscador de windows tecleas "administrador de dispositivos y entras.

Para este punto debes tener conectado tu arduino. Ya aquí empieza lo bueno. Vas a buscar en "PUERTOS (COM y LPT)" tu dispositivo arduino, le das click derecho y la opcion desinstalar

Te puede o va a aparecer una ventana como la siguiente, solo marcas la casilla "eliminar el software..." y le das aceptar

Una vez que termine tu dispositivo arduino va a desaparecer de "PUERTOS..." en el administrador de dispositivos. Actualiza la lista en busca de cambio o desconecta y conecta tu arduino de nuevo. Ahora tu arduino te debe aparecer en la lista de "otros dispositivos" como "dispositivo desconocido" (si tienes varios así deberás hacer el siguiente paso con cada uno de ellos). Das click derecho a este y eliges la opción "actualizar software de controlador"

te va a abrir otra ventana donde eligirás la opción "buscar software de controlador en el equipo"

En la siguente vantana que te abrirá, le das en examinar y buscas la carpeta donde descomprimiste los archivos de los primeros pasos, le das aceptar y siguente

te puede aparecer una ventana como esta, solo elige la opcion de instalar

Y LIIIIIIIISSSSTOOOOOOO...

Cuando termine de instalar puedes abrir el software de arduino y configurar de nuevo el puerto de conexion de tu tarjeta, ahora va a aperecer otra opcion, eligela y podras usar tu arduino.

Espero haya sido de utilidad esta respuesta y que les solucione la vida como a mi, si aun hay preguntas pueden hacerlas y buscamos una solucion

no se porque no se muestran las imagenes, pero si copian la direccion y lo abren a parte si pueden visualizarlas, saludos