Windows Not recognizing Uno

I am running Win& (32bit) and find that it will not recognize my new Uno R3. After some research, I tried in on a different computer and was able to get it work and was able to program it. Switching back to my Win7 machine, It is not recognized. Checking device manager shows no unknown devices. Any ideas on beating my Win7 into submission?

Thanks

Have you tried a USB cable known to be good?

Have you tried a different USB port?

Does the computer make the "device insertion" sounds when you connect the board?

Yes the cable is good. I have used it with the Uno on an XP machine successfully. Also tried different USB ports with no effect. The computer does make the usb connect sound when the cable and device is plugged in. Have also tried rebooting. The computer does work with Leonardo and earlier versions of Arduino.

Thanks

Installed the enhanced release IDE, but it is sitll not being recognized by my Win7 32 bit machine. Checked the device manager and no new devices seen. The computer does make the usb connection sound but that is about the limit of it.

Are you sure the board is working just right now? can you test it again in the xp machine?

I am very new at this and was directed here because of my problem with Windows 7 not recognizing Arduino Uno R3. What I found here is not much in help with particular solutions. While stumbling through different comments, and hoping for a tidbit of info as to solve my problem, I found a solution in that, what seems that others here too were having this problem, having Windows 7 forced to recognize Arduino Uno R3. Sorry for this solution being redundant if this has been suggested before, it is only that the search I did pointed me here, and found nothing to help. There is the importance to have download the file for programming the Arduino boards.

  1. In Windows, the device manager indicates an "Unknown Device."
  2. Hovering the mouse over "Unknown Device", right click and choose "Properties."
  3. A window pops up displaying three tabs (to know you are in the right area). Under the "General" tab click the button "Update Driver."
  4. Another window pops up and gives you two choices, a) have the computer look for update drivers; and b) browse manually for the drivers, click "manually look for drivers".
  5. Another window pops up to direct you to the folder for the new drivers. At the bottom of this window there is a green arrow pointing to "Let me pick from a list." (This action is not updating drivers per say, but telling Windows 7 to add a device and therefore add the drivers). Click on this button.
  6. The next window lists devices already in Windows database. At the top of this list "Show all devices" should be highlighted, if not highlight it by clicking on it. At the bottom of this window click "Next".
  7. The next window again lists Manufacture and Model. At the bottom there is a button with "Have disk". Click this button.
  8. As stated above, maneuver to the folder that you have downloaded from Arduino's web site in which you have installed. Within this folder there is a subfolder called "Drivers". In drivers there is a file called "Arduino Uno REV3" (among others).
  9. Clicking this file will solve the "Unknown Device" and Windows will recognize your new Arduino board.

I hope this helps those with the same problem as I have had.

Moderator edit: turned off smileys

After Step 2 click on driver tab, click on update driver box, click on browse, drop down the selection window and navigate to a path similar to this ""C:\Program Files (x86)\arduino-1.0.1\drivers"" and then click on next. This is how my drivers are installed, from one of my serial ports used for a Mega, I have both installed and working at the same time.

Bob

truthseer - Your directions were Extremely helpful. I know I'm a bit late, but thank you!

I had problems with windows uno7 home premium recognizing my o uno rev 3. Using truthseer's instructions i was able to install the drivers and then had to switch the arduino from com port 7 to com port 1. My problem know is that i am given a code 10 from microsoft. Code 10 is described as "this device cannot start" any idea for my next move? Thanks!

Absolute Genius.
Installing the driver worked. in Windowz 8 64bit.
Thanks a lot.

Hi, Have the same problem as you had, have followed your (very clear ) instructions, but no joy. I get as far as step and click "have disk",next window says "instal from disc" .I am baffled.

I have created a driver installation utility to simplify the driver installation process on Windows.

Download the attachment and launch it. Just follow the prompts then plug in your Arduino.

If all goes as planned, your Arduino should show up with a com port assigned without any further interaction.

Let me know how it goes.

arduino_driver_installer.exe (517 KB)

arduino_driver_installer.zip (466 KB)

Also consider trying a different USB cable. A bad cable could cause problem like what you're describing.

"Exasperated", Tried downloading your attachment, my computer said, I quote, "Arduino driver installer exe, is not commonly downloaded and could harm your computer, Delete Actions Downloads". wont let me download.

I added a zip version of the same file to the original post. Maybe it will let you download that one.

still no luck, tried to download second version (zipped) got the following box; Compressed (zipped) Folders Error. Windows cannot open the Folder.

Have had a personal message to my Email from "eried" Arduino Forum, with a solution. My computer says not to answer.Have "eried" consult through forum.

Hi, I am back again with the same problem. I took Erieds advice and returned the supposed faulty "eleven" and received a replacement. Unfortunately the same problem exists. When I try to upload the sketch, I get the error message "Serial port"com 3" not found". Let me refresh, I have a " freetronics eleven" board about 2 years old, this works perfectly on the original setup (Ard 102) It ALSO works ok on Erieds download (ERW 1.0.4) , it also works on any USB ports. New board wont work on any of the above.
Out of curiosity, how did my sketch history from Ard 102, end up on ERW 1.0.4 as well ?
Chaso

Chaso,

Have you followed the instructions at the following link?

Since the Freetronics board is not an official Arduino, you need to download the Freetronics driver INF file and follow their instructions.