Windows7 64bit & Uno

I just upgraded my HP 200 All-In-One PC with Windows 7 64 bit from Windows 7 32 bit. In device manager under other devices I get USB2.0 serial without a valid driver whenever I plug in the Uno.

I tried the solution of installing the modem driver and any other suggestions I found online.

Nothing seems to work.

Does anyone have any suggestions?


Is it a real arduino of a chinese clone ? if its a clone you should install the DRIVERS

Modem drivers will not do anything for you so you can safely remove those.

Does windows make a sound when you plug in or disconnect the UNO ?

Which IDE are you running ? 1.6.5 being the most stable.

Hi. First time i post in a forum, so i apologize for any mistakes i can make, please, feel free to tell me whatever am doing wrong - i don't want to bother anyone! Also, english is not my mother language, so i may say something worng, or make a bad translation... i hope i won't, but surely i will.

I have almost the same problem. I am trying to connect a Leonardo to a windows 7, and i can't make Windows 7 recognize the device. I open the device manager, look into the BUS controllers, locate the one in wich it is connected, and then i update the drivers (from the same Arduino IDE folder, already instaled - then, from the Hourly Builds actualization, then from the link Ballscrewbob posted up there). Nothing happens, it still is cosidered as a BUS port, and nothing new appears in the COM and LPT ports section. I fear i am missing any step, or maybe doing something wrong. The board works fine in a friend's laptop, so i don't think there is a hardware trouble, there. But the blink of the LED's were different according to where did i connect the USB cable, when i connected it in the front ports, the blinking was much faster than the original setting, but whe i connected it in the rear ports the bliking went normal (also,both LED's blink at the same time, shouldn't it be blinking just one of them?). Thanks in advance for the help, and please, correct me if this is not the right place to post this doubt.

(Original arduino board, IDE 1.6.8, and ONCE it recognized the board as an unidentified device, but the message box dissapeared way too fast from the tasksbar to get details, and it didn't ever appeared again)

The leonardo is probably my least favourite Arduino.

Sorry if this post looks a bit disjointed but am getting out an older Leonardo to play with (URGH)

I always had issues with it dropping com ports during and after programming until its back up.

Thats why you have to add a small statement if you want to read output from the serial port.

void setup() { 
 //Initialize serial and wait for port to open:
  while (!Serial) {
    ; // wait for serial port to connect. Needed for native USB

I have a tinkerkit leonardo (official) and just plugged it in.
It seems to wok fine until I try upload a sketch (using 1.6.5 and 1.6.9) at which point it eventually times out without any errors.
My core is 1.6.10 for the boards

NOTE i know this is the CORES which vary from the IDE so for anyone else reading that doesn't understand
you can update the CORES by going to "TOOLS", "BOARD", "BOARD MANAGER" and clicking "MORE INFO" on the "Arduino AVR Boards" to get your core number.

I just downgraded the core to 1.6.9 and re tried and apart from the warning about deprecated recipe it does the same. the uploading bar disappears eventually but that section still says uploading.

Trying to force a driver update always gives the same result. "your drivers are up to date"

Install your driver is all it took.

Thank you

Thanks a lot! Sorry for taking me so long giving an answer, i've been busy as hell. Karma up (Y) (Y) (Y)