WindowsXP problem with arduino UNO R3

Hello to the forum,

I am reading the last 3 days and i cannot figer out how the winxp recognize my UNO R3 correctly.
I have install and uninstall a lot of times the correct drivers via the device manager.
When I plug the UNO to the laptop usb sometimes I have a message "'Unknown USB device".Then from the the device manager install the correct driver using the "browse" option to select the driver from the "drivers" folder of your Arduino BUT nothing it stay as "'Unknown device".
Other times it reads the UNO correctly in COM7(no other device use it) BUT when I try to send a program I have a message "the serial port COM7 already in use.Try to close all theprograms that use it".
Other times it reads the UNO but it is not working propertly (device manager CODE 10).

The board is ok.I tried to 2 other laptops and work ok.

Please advice
Thanks
Nikos

I do trust that you have performed a "Standard Whindoze Corrective Manoeuvre" (SWCM) at least twice?

Shut down Whindoze, leave power off 30 seconds, restart. XD

Reference:
http://support.microsoft.com/kb/315539

Windows sometimes suffers from USB P&P constipation… simply too many USB devices have been used or the P&P registry entries get hosed.

You Must follow the MS support article and do the steps as outlined:

  • Open command prompt
  • Set the environment variable
  • Open device manager from the command prompt - NOT desktop
  • Set the View Hidden Devices setting in the toolbar
  • Open the Ports (Com & Lpt) branch
  • Delete hidden USB devices that are not active

The next USB com device should take on a low USB number which will increase numerically as additional unique devices are used.

Good luck,

Ray

In the image below, USB port 6 is active, the others are ghosts from previous device insertions and may be deleted. I have found that sometimes the MS procedure does not work correctly unless a device is plugged into the USB… but, other times it works without - your experience will depend on which way the wind is blowing in Redmond :fearful:

Pix shown is from Vista, XP may look a wee-different, but same procedure applies.

Thanks Ray for your help but nothning change…
Note that I have a second UNO that works great on that laptop.

Any other idea?

Try a loopback test, Google or try this explanation:
http://forum.arduino.cc/index.php?topic=73748.0

As the second Uno works, try and narrow it to FTDI or 328 chip.

Ray

Ray the strange is that the "problematic" UNO works great to other 2 pcs BUT not in mine...

Oops :blush:

Does Windoz enumerate the FTDI to a Com port on the PC notebook in question? Is the problem issue on ALL USB ports on the notebook?

It is a puzzler.

Ray

Sorry Ray but what is Windoz ?

WinDoz is Windows™ after you run it for a while… It gets Sooooo Slow… XD

Ray

What to you mean ?
"Does Windoz enumerate the FTDI to a Com port on the PC notebook in question? Is the problem issue on ALL USB ports on the notebook?"

There was a driver configuration inf that told Windows how to manage the drivers for UNO. So, when an Arduino in inserted into a USB port on the PC, it binds the VID/PID pair from the USB chip to that single USB port. Move the Atduini to another port/hub combination and the driver is bound again. A few years ago, notebooks often had 1.1 Ports & 2.0 ports on separate internal hardware, Today, it mostly 2.0 and 3.0 ports or all 3.0.
If the binding matches a past signature for that sane USB device on that port, the prior Com port us enumerated. If it us the first time, Windows takes the next free Com port numeric.

So, moving the Arduino to another port/hub of the notebook can provide valuable diagnostic info.

Ray

I have tested all 4 usb ports that my laptop have with the same results.

BUT right now i connect between Arduino and the usb port an external usb hub AND it works.... XD XD
So as i can understand there is a conflict.How can it be solved?

between Arduino and the usb port an external usb hub AND it works

Oh, my.... Edited...

  • Uno works on 2 other PC's
  • Uno does NOT work on any 4 XP USB ports
  • Uno works through USB hub on XP
  • Uno sometimes enumerates as Com7 but Arduino cannot program "open" port
  • Uno sometimes recognized as unknown device
  • 2nd UNO works great on XP USB port
    OS is WinXP.

I assume the PC hardware is a few years old? Is the USB Hub passive or powered? If the later, the port may not be providing the necessary current (unlikely since 2nd UNO works). If the former, is may be a worn port contacts or the Uno clock may be "off" a weebit... You can use 99% isopropal to clean around crystal/chip area and dry thoroughly before trying again.
Note: on the R3, the area to check is the 32U4 and 16MHz crystal. Any contamination on the board that affects the crystal frequency could be suspect - pulling the crystal off by a little is all that is necessary. Yes, this is very unlikely, but I have seen PC system boards affected by hygroscopic contamination. Yes, at this point I am guessing, too.

Ray