WinXP SP2 - \arduino-0007\arduino.exe no process

Anyone else experienced this problem before? Clicking the arduino.exe to no result? The process doesn't show up within the task manager either. I've been successfully working with arduino-0006 IDE before on my notebook and tried the v7 IDE yesterday on my desktop pc. JAVA 1.5.9 is installed. Did I miss something?

edit: please move this post over to software - just noticed that there are 2 departments, one hardware and one software.

I'm using Windows XP, and whenever I want to start up the IDE, I use "run.bat", not "arduino.exe". Every time I have tried to run "arduino.exe" it just crashes and dies a miserable death. I'm not sure why it even exists or why they bother to ship it.

Thanks, "run.bat" does the job.

CosineKitty: arduino.exe seems to work on most Windows machines (including all the ones I manage to try it on, which admittedly isn’t many). I haven’t been able to discern any pattern about those it doesn’t work on, and since I didn’t write the arduino.exe (it’s a slightly modified version of the processing.exe), I’m not quite sure where to look. Do you have any idea what might cause it? I think it may have something to do with people who’ve got another version of Java installed and in their PATH or CLASSPATH, but I’m not sure. I’ll have to look in to one of these days, assuming I find some people willing to test it.