Wiznet W5100 Ethernet Shield

hello. i have cheap Chinese Wiznet W5100 Ethernet Shield. i used the WebServer example.but the Shield is not working even not giving any responce on ping the IP.

i already fix the IP means i change the IP according to my Network.

Pc IP is 192.168.1.140 Ethernet Shield 192.168.1.177

here is the Link where i Read something About the Reset Pin issue Link so do i need to add the capacitor and resistor on reset Pin.

thank You

The IP address of your PC is irrelevant. What IP address does your router assign to the Arduino? You are connecting the Arduino to a router, aren't you?

yes i am using Network switch.
for simplicity i just connect the pc to the switch and the arduino to the switch
i also have controllino, which is working on the same code and the same cable
but this shield is not working.

The correct ratio of answers to questions is 1:1, not 1:2.

The Arduino ethernet shields have trouble with some brands/models of switches. Which switch are you using?

edit: Have you tried connecting the ethernet shield to the PC directly without the switch?

thank you. problem is solved..i just change the switch

atifbuitms: thank you. problem is solved..i just change the switch

From what brand to what brand? Helping to document which switches work, and which don't, would be doing the community a favor.