Wont power up

I have the Duemilanove with the atmega 168 on windoes. I plug the board into the usb port and the green power led on board dosent light up. So i checked to see if i had the right serilal port wich myn is COM 4 and there isnt an option for com 4 iv uploaded sketchs to the board before but all of a sudden nuthing?

can anyone help me? :)

No green power light means the board is fried, or the USB port is disabled. USB ports will shut down if overloaded, but generally reset like a fuse if you power cycle the computer.

What happens if you try a power adapter or a battery? Center of the jack is positive.

it worked with a power jack i had a servo and a pot hooked into it so i guess i had it hooked up wrong or something because the arduino woundnt work with it hooked up so i unhooked it rehooked then it worked. I dont know why

i had a servo and a pot hooked into it

Servos draw quite a lot of current, so that may have damaged something, either in the USB port or the Arduino. Can you use the same USB port to power other USB devices?

It doesn't sound like anything was damaged. Try powering the servo from an external power supply. Don't forget to connect the Power supply ground to the Arduino Gnd.