WProgram.h

I’m uploading to my board (DFRduino Unov3.0 [r3]) and this error shows up.

Arduino: 1.8.5 (Windows 10), Board: “Arduino/Genuino Uno”

C:\Users\Judd\Documents\Arduino\libraries\LiquidCrystal\LiquidCrystal.cpp:6:22: fatal error: WProgram.h: No such file or directory

#include “WProgram.h”

^

compilation terminated.

exit status 1
Error compiling for board Arduino/Genuino Uno.

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

I did the last paragraph and this shows up

Arduino: 1.8.5 (Windows 10), Board: “Arduino/Genuino Uno”

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Judd\Documents\Arduino\libraries -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0043 -ide-version=10805 -build-path C:\Users\Judd\AppData\Local\Temp\arduino_build_213700 -warnings=none -build-cache C:\Users\Judd\AppData\Local\Temp\arduino_cache_320855 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\Judd\Documents\Arduino\sketch_mar13d\sketch_mar13d.ino
C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Judd\Documents\Arduino\libraries -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0043 -ide-version=10805 -build-path C:\Users\Judd\AppData\Local\Temp\arduino_build_213700 -warnings=none -build-cache C:\Users\Judd\AppData\Local\Temp\arduino_cache_320855 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avrdude.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\Judd\Documents\Arduino\sketch_mar13d\sketch_mar13d.ino
Using board ‘uno’ from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr
Using core ‘arduino’ from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr
Detecting libraries used…
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino” “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard” “C:\Users\Judd\AppData\Local\Temp\arduino_build_213700\sketch\sketch_mar13d.ino.cpp” -o “nul”
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino” “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard” “-IC:\Users\Judd\Documents\Arduino\libraries\LiquidCrystal” “C:\Users\Judd\AppData\Local\Temp\arduino_build_213700\sketch\sketch_mar13d.ino.cpp” -o “nul”
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino” “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard” “-IC:\Users\Judd\Documents\Arduino\libraries\LiquidCrystal” “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\SPI\src” “C:\Users\Judd\AppData\Local\Temp\arduino_build_213700\sketch\sketch_mar13d.ino.cpp” -o “nul”
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino” “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard” “-IC:\Users\Judd\Documents\Arduino\libraries\LiquidCrystal” “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\SPI\src” “C:\Users\Judd\Documents\Arduino\libraries\LiquidCrystal\LiquidCrystal.cpp” -o “nul”
“C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-g++” -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10805 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\cores\arduino” “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\variants\standard” “-IC:\Users\Judd\Documents\Arduino\libraries\LiquidCrystal” “-IC:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\SPI\src” “C:\Users\Judd\Documents\Arduino\libraries\LiquidCrystal\LiquidCrystal.cpp” -o “C:\Users\Judd\AppData\Local\Temp\arduino_build_213700\preproc\ctags_target_for_gcc_minus_e.cpp”
C:\Users\Judd\Documents\Arduino\libraries\LiquidCrystal\LiquidCrystal.cpp:6:22: fatal error: WProgram.h: No such file or directory

#include “WProgram.h”

^

compilation terminated.

Using library LiquidCrystal in folder: C:\Users\Judd\Documents\Arduino\libraries\LiquidCrystal (legacy)
Using library SPI at version 1.0 in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr\libraries\SPI
exit status 1
Error compiling for board Arduino/Genuino Uno.

Thanks for any help

You seem to be using an old version of the LiquidCrystal library.

There is also no need to install one in the sketch folder; the IDE installation comes with one.

I suggest that you remove the library from C:\Users\Judd\Documents\Arduino\libraries.