wrong Signature ATTiny Programmer (using Arduino)

Hi all, I really appreciate your help, please dont let my request unanswered!

I know they are some other related discussions, but it has not helped me.

Problem description: I want to program a Attiny 45 and also Attiny85 through an arduino Nano. The wicked thing is that I had already succeeded in doing this two weeks ago, now I can't get it to work.

I am using the instructions from this tutorials [http://www.instructables.com/id/Attiny-Programmer-using-Arduino-UNO/[/url

or from here: http://highlowtech.org/?p=1695

I checked the pin and cables many times and have built it with different configurations and it is not the reason of the problem. I also tried with an arduino nano and arduino mega.

I tried with different ATtiny 45 or Attiny85 - same results for all.

I am really following the instructions, loading the ArduinoISP program into the nano, then attaching a 1uF or 10uF Capacitor between RST and GND and changing the board configuration to ATtiny85, 1MHz, Arduino as ISP

I have even followed one of the forum discussion suggestions to attach a 110 Ohm resistance (100 + 10) between 5V and RST.

I am getting this error message in arduino IDE:

Sketch uses 678 bytes (8%) of program storage space. Maximum is 8192 bytes. Global variables use 9 bytes (1%) of dynamic memory, leaving 503 bytes for local variables. Maximum is 512 bytes. avrdude: Expected signature for ATtiny85 is 1E 93 0B * Double check chip, or use -F to override this check.* Wrong microcontroller found. Did you select the right board from the Tools > Board menu?

what I am doing wrong? what can I change. I even tried to double check the signatures from the ATtiny datasheet and correlated them with the avrdude.conf

I have not yet tried to load it through the terminal with avrdude and -F ( overriding invalid signature check). but as I wrote earlier, it worked out without it last time.

1000x Thanks in advance!

Elias

](http://www.instructables.com/id/Attiny-Programmer-using-Arduino-UNO/)

(deleted)

Please do this:

  • File > Preferences > Show verbose output during: > compilation (uncheck) > upload (check) > OK
  • Tools > Burn Bootloader
  • After the process fails you’ll see a button on the right side of the orange bar “Copy error messages”. Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the toolbar).

PanzerKnacker77:
I have not yet tried to load it through the terminal with avrdude and -F ( overriding invalid signature check).

Overriding the signature check is almost never the solution. Usually a signature mismatch indicates something is messed up to the point where the process would just fail at a later step.