ws2801 not working properly with FastSPI_LEDS2

I’m trying to drive a ledstrip of ws2801’s, but it is not working. I’ve connected the strip to the Arduino’s +5v and gnd, I know this doesn’t deliver enough juice to drive the whole strip, but for testing I just want to light a couple up.

When I run the code listed below one led lights up, it starts out dim orange, and gets gradually brighter, after it’s on full brightness nothing happens anymore. I tried switching the clk and dat pins around to no avail.

#include "FastSPI_LED2.h"

#define NUM_LEDS 150

#define DATA_PIN 11
#define CLOCK_PIN 13

CRGB leds[NUM_LEDS];


void setup () {
  delay(200);
  FastLED.addLeds<WS2801, DATA_PIN, CLOCK_PIN, BGR, DATA_RATE_MHZ(1)>(leds, NUM_LEDS);
}


void loop () {
   // Move a single white led 
   for(int whiteLed = 0; whiteLed < NUM_LEDS; whiteLed = whiteLed + 1) {
      // Turn our current led on to white, then show the leds
      leds[whiteLed] = CRGB::White;

      // Show the leds (only one of which is set to white, from above)
      FastLED.show();

      // Wait a little bit
      delay(1);

      // Turn our current led back to black for the next loop around
      leds[whiteLed] = CRGB::Black;
   }
}

Never mind, apparently it matters whether you connect them backwards or not :s.