ws2803d difficulty

I know very little about electronics, so please bear with me.

I am trying to use an Arduino UNO and a WS2803d to control a led light strip SMD5050 (http://www.amazon.com/gp/product/B00ASHQQKI/). I was able to control the strip directly using the Arduino’s PWM, but have been unable to get the WS2803d to work. I have used several different pieces of code from similar projects, but have been unable to get the WS2803d to pass on anything to the led strip.

I attached a picture of the breadboard. I tried a number of different configurations. With and without decoupling capacitors, with and without the resistor for IREF. I also tried a few different WS2803d chips, but I bought them all off of ebay so I wonder if perhaps they are all dead?

If someone has any ideas of what else to try, or something that has worked for them it would be great.

Thank You!

Hi, could you post a copy of your circuit for us to check.

From other threads this device can be some trouble to control with the number of libraries around for it.

The circuit could even be a scanned drawn diagram.

Tom... :slight_smile:

I attached an image to the first post, I am not sure how else to post it. I had to log in to see it? I am attaching a fritizing diagram to this post.

IMGF.png

Hi
did you get it going.
If not are you sending to the right output ?
Looks like out 0-2
And could you put a led in place of the driver ?