WS2811 Neopixel circuit troubleshooting

Hi
We have built a ring consisting of 19 Adafruit Neopixels (white)

We were testing it happily using various FastLED demos and it was working as intended, however something seems to have happened and now the ring doesn’t work properly.

Now only the first two LEDs light up.

The voltage is still travelling around the whole ring, and it seems the data is as well as the timing of the patterns is consistent with how it was when it was all working.

We’ve tried various codes and the same thing is happening.

We cut LED19 which wasn’t working in the circuit off and tested it individually - it worked.

Can anyone please suggest how we could test / repair this further without desoldering the entire thing?

Many thanks!

Hi,
Welcome to the forum.

Please read the first post in any forum entitled how to use this forum.
http://forum.arduino.cc/index.php/topic,148850.0.html . Then look down to item #7 about how to post your code.
It will be formatted in a scrolling window that makes it easier to read.

Can you please post a copy of your circuit, in CAD or a picture of a hand drawn circuit in jpg, png?

Thanks.. Tom.. :slight_smile:

Hi,
I thought the NeoPixel PCBs were designed to be simply daisy chained to each other.
Your setup looks like you have crossing wires and jumpers.

Can you post a link to the LEDS.
A closeup pic of the PCB with its pinout labels, or a hand drawn diagram of the pinout labels in the NeoPixel PCB?

Although this is a pic of RGB NeoPixels, you can see how easy the interconnections should be.

Tom.... :slight_smile:

Do you have the recommended 0.1uF capacitor between +Vcc and Gnd on each neopixel, and the series resistor between the arduino output pin and the first neopixel input?

What are you using for a power supply? Nineteen neopixels will need around 1.14 amps at 5 volts when they are all lit at full brightness.

If only the first 2 are lighting up then either power, ground or data is broken between 2 and 3.

Power and ground are easy to test with a multimeter. Data is not so obvious. Your assumption on timing is incorrect. The Arduino cannot detect if there is a break in the data line.

You don't appear to have connected up any of the data lines for the LEDs.

Can you post a link to those neopixels on the PCB please.

By the way Neopixels are WS2812 not WS2811.

Your soldering iron is not set to be hot enough to make proper joints.