WS2812 LED Strip Not Responding to Uploaded Code

So I got this new WS2812 LED strip 2 days ago, and I’ve been wanting to mess around with animations. Except that the strip just stays on this red/orange state (attached picture), and doesn’t react to the uploaded code at all.

The data pin is set to digital 6.

Ground from the arduino is connected to the ground pin directly to the led strip.

Power is supplied to the strip via VIN from the arduino directly to the strip (I’ve tried using 5v from the arduino to the strip as well, but I still get the same results).

I got this code from the ALA library page. No compile or upload errors are given when uploaded to the arduino.

#include "AlaLedRgb.h"

AlaLedRgb rgbStrip;

void setup()
{
  // initialize the WS2812 strip with 30 leds on pin 6
  rgbStrip.initWS2812(30, 6);
  
  // set a color-fading animation with a duration of 5 seconds and an RGB palette
  rgbStrip.setAnimation(ALA_FADECOLORSLOOP, 5000, alaPalRgb);
}

void loop()
{
  // run the animation
  rgbStrip.runAnimation();
}

Any suggestions on what may be the issue are appreciated!

2a88e44ab259b967ddcdf49b89321988d8bdbc61.jpg
3f9052f3817579e6d681100c2af6580e959022e5.jpg

Go find a neopixel tutorial on the Arduino, Sparkfun or Adafruit websites. Follow one of those and don't take any shortcuts. And hope you have not already damaged you Arduino.