WS2812B LEDs are not working with Arduino Uno

I recently bought 1m of WS2812B with 60 LEDs to be controlled with an Arduino Uno. I build my circuit based on the picture attached below. I have included the code (strandtest)that I tried to use to light up WS2812B. Out off 60 leds, I just used 30 leds


#define PIN 6

// Parameter 1 = number of pixels in strip
// Parameter 2 = pin number (most are valid)
// Parameter 3 = pixel type flags, add together as needed:
//   NEO_KHZ800  800 KHz bitstream (most NeoPixel products w/WS2812 LEDs)
//   NEO_KHZ400  400 KHz (classic 'v1' (not v2) FLORA pixels, WS2811 drivers)
//   NEO_GRB     Pixels are wired for GRB bitstream (most NeoPixel products)
//   NEO_RGB     Pixels are wired for RGB bitstream (v1 FLORA pixels, not v2)
Adafruit_NeoPixel strip = Adafruit_NeoPixel(30, PIN, NEO_GRB + NEO_KHZ800);

void setup() {
    strip.begin();; // Initialize all pixels to 'off'

 void loop() {
    // Some example procedures showing how to display to the pixels:
    colorWipe(strip.Color(255, 0, 0), 50); // Red
    colorWipe(strip.Color(0, 255, 0), 50); // Green
    colorWipe(strip.Color(0, 0, 255), 50); // Blue
    // Send a theater pixel chase in...
    theaterChase(strip.Color(127, 127, 127), 50); // White
    theaterChase(strip.Color(127,   0,   0), 50); // Red
    theaterChase(strip.Color(  0,   0, 127), 50); // Blue


// Fill the dots one after the other with a color
void colorWipe(uint32_t c, uint8_t wait) {
    for(uint16_t i=0; i

After set up the circuit based on the picture below.I powered up WS2818B LEDs by using 5V 2A Samsung's power adapter. When I switch on the power adapter, two leds light up with green color( I haven't load the code yet). I off the power adapter and on back now three led with different color light up.Then I load the strandtest code(ADAFRUIT) to the arduino uno but the WS2818B LEDs still output the same result (Only two green colored LEDs light up). I have checked many forums regarding this problem but none of them can resolve my problem. Can someone help me about it?



|500x293 |500x375

Can you post a close up of the connections to the strip?

Can you upload the blink sketch and see the built-in led flashing?

Basically you either have faulty components or more than likely you are doing something wrong. Until we can see what you have done we can't say what you have done wrong. That code works and that circuit works, so we can rule out design errors, so that only leaves your implementation.

As you claim to have asked on other forums I am astonished you provide so little information to us.

PaulRB this is my connection to strip. My soldering skills sucks but I have make sure that any of the wires does not touch each other. As you said I have upload the blink sketch code too to make the build in led of arduno to blink and the build in led is blink.

Grumpy_Mike what you said is true. It is my fault that I does not provide enough information on other forum.

Your pictures show only part if the circuit. We need to see it all. The choice of yellow, yellow and yellow for +5, signal and ground is not good for spotting errors.

That signal joint doesn't look correctly soldered to me. It looks like "dry joint".

Please learn to post pictures correctly. Helps us to help you!




Sorry to use the same color for all three wires. I have reconstruct the circuit so that it look more tidy and clear. I have no idea how to upload the image that is why I attached the image.![](

no idea how to upload the image

see this image guide

Thiyraash96: I have no idea how to upload the image that is why I attached the image.

You were half way there when you attached the images before. Now you have gone backwards. If you were in charge of a forum, how would you let people know how to post images, links and code?

I'm sorry for does not post the picture properly.|500x375


You have no common ground between the Arduino and your external power supply.

Run a wire from the Arduino ground to the ground on the bread board.

That is why we needed to see all your wiring.

Grumpy_Mike: You have no common ground between the Arduino and your external power supply.

Mike, I think that's the white dupont wire you can see.

So what might be the problem? Faulty component?

Next, check all the wiring with a multimeter. Perhaps you have faulty connections somewhere. Those DuPont wires are notoriously unreliable in my experience. Check each one using the resistance mode on the multimeter. Check the resistance of that resistor is as expected. Use the voltage mode to check that you have 5V all the way to the end of the strip.

Another possibility is that the first led in the strip is faulty. See what happens if you connect the data wire to the pad for the second led.