xbee konfiguration via coolterm / x-ctu nicht möglich

Hallo betreibe ein xbee S1 via ein Wireless Sd shield am arduino leonardo undwollte für den sleep modus einige Parameter einstellen über Coolterm / x-xtu doch das Modem wird nicht erkannt->> habe alles versucht doch bei der +++ eingabe bekomme ich kein Ok feedback.

Was kann das sein ? Bitte um Hilfe

Danke sehr

Hallo,
beim programmieren der Dinger müssen Tx & Rx vertauscht werden.
Beim Senden und Empfangen dann wieder richtig anschließen.
Gruß und Spaß
Andreas

Hi inwiefern vertauscht? muss ich den xbee pin rx an tx von arduino?
Durch den Switch von Micro → USB müsste das doch der fall sein oder? (siehe Wireless sd shield von Arduino)?
Bzw wie ist das gemeint? HAst du vllt ne einleitung als Link, ist das erste mal, dass ich das höre, in allen anderen nicht gelesen

Hallo,
ich hoffe es hilft Dir ein wenig weiter:

Ist vielleicht etwas missverständlich gewesen:
"Sie müssen den Arduino vom XBee trennen, bevor Sie ihn programmieren.
Das liegt daran, dass der Arduino die Pin´s 0 und 1 für die
Programmierung nutz. Die Signale kommen sich dann mit allem in die
Quere (z.B. dem XBee), was an diesen Pin´s angeschlossen ist."
Quelle:Arduino Kochbuch
Gruß und Spaß
Andreas

Danke sehr Andreas, es hat funktioniert :D.

Sehr herzlichen dank und ein erneutes Lob an diesem Forum ;).

Es geht :smiley:

Hallo,
ich habe für die Rückmeldung zu Danken.
Viel Spaß noch dabei.
Andreas

Nichts zu danken , gerne :smiley:

Kurze Frage noch, Hab in dem Datasheet von XBee etwas über Dio7 (Pin) gelesen, wozu ist dieser Pin, verstehe das nicht ganz

Gruß
Luigi

Hallo,
das sind Ein/Ausgänge die Du konfigurieren kannst.

http://www.digi.com/wiki/developer/index.php/Configuring_Digi_XBee_Modules

Frage mich aber nicht, wie es funktioniert.
Gruß und Spaß
Andreas