xbee s1 and olimex Mod-zigbee

i want to form a xbee network using the adruino s1 xbee and an olimex mod-zigbee 802.15.4 board(https://www.olimex.com/Products/Modules/RF/MOD-ZIGBEE/resources/MOD-ZIGBEE.pdf). i have tried setting panid's and channels on both devices to the same, but that hasn't solved my problem. could anyone shed some light?


There is a lot of marketing blabla in the area of the bees confusing the average user (including me). An XBee is not a ZigBee module by definition (although, as fas as I understood it, it can be made one by changing the firmware). The MOD-ZIGBEE datasheet doesn't specify if it's compatible with standard S1 Digi Inc. XBees so I wouldn't bet on it.

S2 series is billed as Zigbee, S1 series is not. Maxstream [now Digi] didn’t have enough code
space in the microcontrollers used in the original S1 modules to implement the full Zigbee
mesh protocol, so you can’t simply reflash them with Zigbee firmware after the fact. So
they developed the S2 modules to fix this.

im almost sure the mod-zigbee is 802.15.4 and not full zigbee stack.