XBee S2C IO Pins

I have a setup that consists of one Xbee S2C connected to rx3/tx3 (so I’m using Serial3) of an Arduino Mega set up as the coordinator and another XBee connected to an Explorer Regulated Board. I have set up my end device such as to read a potentiometer from DIO3. In my XCTU configuration, I set up DIO3 as ADC [2] and I have a sample rate of 1000ms.

I know my XBees are connected to each other because of the LEDs on the boards, and I know that the cordinator (attached to Arduino) is receiving something every 1000ms (from the blinking) so the configuration is correct. I even tried something along the lines of this (XBee Shield Hookup Guide - learn.sparkfun.com) and it worked.

Now, the end device (potentiometer XBee) is attached to the breadboard with 5V and GND attached to the appropriate pins and a potentiometer is attached to DIO3. This XBee does not blink at all (other that PWR) so that makes me think that the problem is with this XBee. I am inputting 5V and GND into the potentiometer (per usual) and I am not using VREF at all (I think this XBee has hardware for that and the board has no VREF pin).

What could be the problem? Should I not input 5V to the potentiometer although the board takes care of regulating power to 3.3V?

Bump

Sir, can u give me code for configure xbee s2c on arduino? i have some trouble when i try to connect each other xbees on arduino. thanks before