XD-RF-5V receiver and RCSwitch problem

I downloaded and installed the RCSwitch library, and, firstly attempted to run the ReceiveDemo_Advanced script on a Nano using the receive module (433MHz).

Absolutely nothing in the Monitor! So, I inserted a "Hello World" in the setup just to make sure it was loading, and that went OK.

I double checked the garage door transmitter was 433MHz (it was in the manual). I purchased 5 sets of these transmitter receiver pairs on eBay (cheap,cheap), so I had a few to try in case one was dead, but it was the same result every time. I then loaded the same onto a Duemilanove. Exactly the same. I'm stumped....

Wiring has been double checked. Der :slight_smile: it's only 5V, GND and pin2 (Int0). The voltage coming out of the 5V pin was about 4.58V.

Well, I've just added a 17cm aerial to the receiver, and still no response to anything. Could it be that I got 5 sets of duds from eBay??

The RCswitch library is designed to decode transmissions from devices that use the SC2262 encoder chip.
If your garage door opener doesnt use this chip, then you wont decode anything.
Most garage door openers use rolling code transmitters to provide extra security, and dont use the SC2262 chips.

Thanks for that info. I'll try something else. I really appreciate the reply, because I was stumped!