(yet another) avrdude: stk500v2_getsync(): timeout communicating with programmer

HI!

Trying to update ATMega2560 firmware on MacOS Mavericks, this is what I've done so far:

  1. installed latest Arduino software (nightly)
  2. chosen the correct board and processor (yes, board DOES appear recognized by MacOS)
  3. tried different USB ports on the computer
  4. uploading firmware makes the TX blink for a sec and every time it blinks, a timeout is displayed in the verbose window.
  5. tried to disable stock Apple FDMI drivers and installed old ones
  6. did a search+replace any !!! instance by just !

Still timeing out.

I've also tried resetting the board before, during and after the upload takes place with no luck.

What else could be failing??

Thanks!

Is it new board or old board?? ru purchased from Ebay???

Above error comes beacuse

  1. wrong port & wrong board being chosen
  2. you have allotted TX & Rx lines ; means some interface you may connected tx & rx lines
    3)boot loader crashed. u need use avr pocket programmer
  1. I'm pretty sure it's not a wrong port/board chosen error.

  2. Not sure wdy mean by alloted TX/RX lines, this happens no mater if i just turn the board on (plugging the usb cable) or reset it before/during/after compilation occurs

  3. board is brand new, cant think of a reason why bootloader crashed. item is brand new from an online store in my country.

  1. Not sure wdy mean by alloted TX/RX lines, this happens no mater if i just turn the board on (plugging the usb cable) or reset it before/during/after compilation occurs

are used the TX & RX pins as interface. If you connected any interface remove it & upload blink example.

board is brand new, cant think of a reason why bootloader crashed. item is brand new from an online store in my country

I have worked with 2 to 3 vendor
for example arduino uno orginal from sparkfun cost you 1700RS in India
if we purchasing non trust vendor XXX there cost is around 800RS. The main problem is you get board at lower price. I found some library function won't work.

In case of arduino mega, Tx and Rx lines get shorted or over solder can be found . So i told whether you purchase from trusted vendor or cheaper one.

Forgot to mention ATMega2560 is on a RUMBA board...

you are placing rumba board on arduino mega as stack. Then you need to remove rumba board, upload the code. this time it will work.

I already told you if any interface connected to mega board remove it. then upload the code.Let me know if any error you got this time

No, RUMBA board has the arduino "embeded", not as a shield.

http://support.typeamachines.com/hc/en-us/articles/202642235-Uploading-Firmware-to-the-RUMBA-Motion-Control-Board

go through the link once.
i think you should try with latest version of arduino IDE once.

That is the exact process I followed, which lead me to open this thread. I've tried with Arduino 1.6.0 and Arduino Nightly links but I think they download the same software... Anyhow, I tried with both. Same results.

THis is the actual output in verbose mode:

var/folders/rx/n_cc_q752498v_6xwx1jtt9m0000gn/T/build65663422568611514.tmp/Marlin.cpp.elf /var/folders/rx/n_cc_q752498v_6xwx1jtt9m0000gn/T/build65663422568611514.tmp/Marlin.cpp.hex

Sketch uses 102.862 bytes (40%) of program storage space. Maximum is 253.952 bytes.
Global variables use 4.376 bytes (53%) of dynamic memory, leaving 3.816 bytes for local variables. Maximum is 8.192 bytes.
/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf -v -patmega2560 -cwiring -P/dev/tty.usbmodemfa131 -b115200 -D -Uflash:w:/var/folders/rx/n_cc_q752498v_6xwx1jtt9m0000gn/T/build65663422568611514.tmp/Marlin.cpp.hex:i

avrdude: Version 6.0.1, compiled on Apr 3 2014 at 22:00:33
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf"
User configuration file is "/Users/alex/.avrduderc"
User configuration file does not exist or is not a regular file, skipping

Using Port : /dev/tty.usbmodemfa131
Using Programmer : wiring
Overriding Baud Rate : 115200

avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

avrdude done. Thank you.

again, for every "avrdude: stk500v2_ReceiveMessage(): timeout" printed in the console, a TX led blink occurs...

any clues?

thanks!

I have not used the board above.

As i said In case of arduino Mega. The above error you mentioning comes while bootlooder crashed.
If it brand new board i doubt it crashed bootlader.

if it is brand new board they also provide the technical sheet. Just look into that . just upload example code they given.

If you ask me , If there is programmable port available like Avr pocket programmer**(label: ICSP)** i would upload the bootloader once.

Then upload the example code associated with board.

I gave up on the mac.... Once I loaded Arduino on a RasPiB+ it worked nice.

Thanks anyway.