Yet Another Serial Port Greyed Out on Arch 64bit

I am running a Arch Linux Installation which has been succefully working with Arduino 0018 for a while.Recently I decided to update to the 0022 version to support some UNO boards I had bought.

The problem lies that the Tools>Serial Port menu is greyed out and it is currently impossible to upload any sketches.

[u]Installation:[/u]

sudo pacman -Rs arduino
yaourt arduino

[u]lsusb:[/u]

Bus 007 Device 002: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

[u]lsusb -v:[/u]

Bus 007 Device 005: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0         8
  idVendor           0x0403 Future Technology Devices International, Ltd
  idProduct          0x6001 FT232 USB-Serial (UART) IC
  bcdDevice            6.00
  iManufacturer           1 FTDI
  iProduct                2 FT232R USB UART
  iSerial                 3 A9007WcW
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           32
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower               90mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol    255 Vendor Specific Protocol
      iInterface              2 FT232R USB UART
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               0
Device Status:     0x0000
  (Bus Powered

[u]dmesg[/u]

[ 1898.163434] usb 7-1: new full speed USB device number 2 using uhci_hcd
[ 1898.359311] ftdi_sio 7-1:1.0: FTDI USB Serial Device converter detected
[ 1898.359410] usb 7-1: Detected FT232RL
[ 1898.359417] usb 7-1: Number of endpoints 2
[ 1898.359422] usb 7-1: Endpoint 1 MaxPacketSize 64
[ 1898.359428] usb 7-1: Endpoint 2 MaxPacketSize 64
[ 1898.359432] usb 7-1: Setting MaxPacketSize 64
[ 1898.361164] usb 7-1: FTDI USB Serial Device converter now attached to ttyUSB0

[u]prefferences.txt entries:[/u]

serial.port=/dev/ttyUSB0
serial.debug_rate=9600

[u]port permissions:[/u]

ls -l /dev/ttyUSB0
crw-rw---- 1 root uucp 188, 0 Jul  9 19:07 /dev/ttyUSB0

[u]group permissions:[/u]

cat /etc/group
uucp:x:14:minoas,root

[u]testing Serial:[/u]

cat "e" > /dev/ttyUSB0

With Serial Testing and a Demilanove board led L is flashing.On same computer and with Windows7 64Bit the IDE is working good but slower than linux.Running it as root did also not enable the menu.Tried different cable configurations but it seems to be a software ussue.

I am using Sun JRE6.Any help is greatly appreciated...

try running as root.

Running as root was one of the first thing I tried.Serial Persmissions seem to be ok.

[u]Status update[/u]

[u]Actions performed since last post:[/u]

  • Removed gcc-avr and dependecies and reinstalled them
  • Reinstalled binutls
  • Fallback on a demilanovae board.If I manage to make this one work I will check the uno
  • Tested board + cable on Windows7 and Mac machines.
  • Downloaded versions 018 to 022 of arduino and tried running the arcuino script.The IDE loads but the tools Serial port remained Greyed out
  • Tried Latest Tarball with latest rxtx .so and .jar from http://rxtx.qbang.org/wiki/index.php/Download
  • Tried another USB port
  • Tried Sun JRE7 and openJDK6
  • Searched entire system for strays rxtx

From my understanding the main culprit for Greyed out Serial Port is the librxtx.There is also a compile bug of latest gcc-avr but fixed by downgrade and I doupt it effects the menu selection.Also UNO boards should create /dev/ttyASM* while demilanovae should create /dev/ttyUSB*

Any help is really appreciated since the issue is getting quite irritating.Compiling for arduino on windows is taking much longer than on linux.

Just as a point of reference, I installed version 22 on the latest release of Mint 64 bit and all was well.

Jim.

I finally isolated the issue and managed to fix it.I am posting how just in case someone encounters the same problem.

I did notice the /var/lock directory missing so what I did was

Reinstall filesystem

sudo pacman -S filesystem

Change its group persmissions to uucp

sudo chgrp uucp /var/lock

After that sketches uploaded fine.Have fun