Yet another stk500_getsynch() error with avr programmer

I have been programming with Arduino as ISP to my ATtiny85s no problem. I purchased the Olimex stk compatible USB programmer https://www.sparkfun.com/products/8702 so I could use the ICSP on my little 8 pin AVR dev board, https://www.sparkfun.com/products/33. I am getting the cursed getsynch 0X00 error. I can see the Programmer flashing on upload but it errrors out.

I am using the Arduino software 1.01 Attiny 85 20MHZ 8 pin chip AVR stk compatible USB programmer Trying to upload the Examples/Basic/Blink program for testing purposes

I tried a second ATTiny85 as well.

I am not using external power on the dev board.

All suggestions appreciated

R

Do you have the six-pin connector the right way around?

Yes, good question. I have the red edge of the cable closest to the number one pin on the ICSP header.

Arduino as ISP works on the same ATtiny85?

Are you trying to program the ATtiny85 through the Arduino IDE?

Yes, the Arduino can program ATtiny85s and no I am not trying to go that now. I am using an AVR USB programmer.

rheine: ...no I am not trying to go that now.

Not trying to program through the Arduino IDE?

I am programming through the Arduino IDE software but not Arduino as ISP

Post the verbose output from an upload attempt.

Binary sketch size: 832 bytes (of a 8,192 byte maximum) avrdude: stk500_getsync(): not in sync: resp=0x00

I assume from your reply you don't know what I meant by "verbose output".

http://arduino.cc/forum/index.php?topic=115816.0 http://arduino.cc/forum/index.php/topic,124444.msg939468.html#msg939468

Yes, you are correct. See attached

verbose.txt (28 KB)

C:\Program Files\arduino-1.0.1\hardware/tools/avr/bin/avrdude
-CC:\Program Files\arduino-1.0.1\hardware/tools/avr/etc/avrdude.conf
-v -v -v -v
-pattiny85
-cstk500v1
-P\.<mark>COM4
-Uflash:w:C:\Users\Rick\AppData\Local\Temp\build4840937731211437691.tmp\sketch_nov03b.cpp.hex:i

Is the programmer on COM4?

Using Port : \.\COM4
Using Programmer : stk500v1
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Recv:
avrdude: stk500_getsync(): not in sync: resp=0x00

…indicates that the programmer did not respond.

Do you know for a fact the programmer works? Have you used it with other programming tools like AVR Studio or avrdude from the command line?

From the Users Manual…

AVR-ISP500 is USB low cost in-system programmer for AVR microcontrollers. It implements the STK500v2 protocol…

You have it configured to use the wrong protocol.

OK, that makes sense. I think I need to change a parm in the arduino avrdude.config file but not sure where. I open it as txt and it's not clear. The board I selected from /tools defaults to V1.

You need to change boards.txt and/or programmers.txt. The two together form a mapping between a board and a programmer.

I don't have a programmers.txt but I did find this in the avr.conf. I tried putting in V2 but it gave me a syntax error.


ATtiny85

------------------------------------------------------------

part id = "t85"; desc = "ATtiny85";

has_debugwire = yes; flash_instr = 0xB4, 0x02, 0x12; eeprom_instr = 0xBB, 0xFF, 0xBB, 0xEE, 0xBB, 0xCC, 0xB2,

0x0D, 0xBC, 0x02, 0xB4, 0x02, 0xBA, 0x0D, 0xBB, 0xBC, 0x99, 0xE1, 0xBB, 0xAC;

no STK500

devcode in XML file, use the ATtiny45 one stk500_devcode = 0x14;## avr910_devcode = ?;

Try the AT90S2313

rheine: I don't have a programmers.txt ...

{Arduino Installation Directory}\hardware\arduino\

but I did find this in the avr.conf

Modifying the avrdude.conf file will not solve the problem.

Finally found that file. Changed over to V2, same result.

AVR ISP avrisp.communication=serial avrisp.protocol=stk500v2avrispmkii.name=

After amking my changes to the programmers.txt, I restarted the IDE and it's in stk500v2 protocol now but I am getting a device signature error.

If the signature is all zeros the problem is very likely wrong wiring or the target is not clocked.

If the signature is invalid the problem is very likely loose wiring, unconnected wiring, or the SPI rate is too high.

If the signature is valid bug wrong the boards.txt entry is wrong or you have the wrong board selected.