Yosemite OS and Arduino USB ports not recognised by the IDE (Arduino Gemma)

Good morning,

I have quite of a problem with my Mac and the Arduino IDE.

I bought an Arduino Gemma and I can’t use it because my Arduino IDE doesn’t recognise the USB ports.

So far I tried these things and non of them worked:

I have downloaded the Arduino IDE 1.6.5 version.
I downloaded the FTDIUSB serial driver and followed the instructions of this thread: http://forum.arduino.cc/index.php?topic=198539.0
Tried this thing instead http://arduino.stackexchange.com/questions/5119/arduino-nano-no-serial-port-for-macbook-air-2013
I switched to different USB cables
I downloaded Java 8

I am desperate and I don’t know what to do.

My system recognise the Gemma board, but apparently the IDE don’t. (see attachments)

Please help!

I have to run a workshop soon and I don’t know how to fix this issue!!!

Many thanks to whom is going to reply.

Screen Shot 2015-07-14 at 11.53.05.png

Screen Shot 2015-07-14 at 11.54.08.png

Just a quick update:

I tried to plug my Gemma board to an USB 2.0 hub, but again... Nothing happened :(

Good morning,

It seems the solution is in this tutorial:

https://learn.adafruit.com/add-boards-arduino-v164/installing-boards

However, when I try to download the plugin from the "boards manager" as shown, the Adafruit AVR plugin doesn't show up. :(

I figured it out.

I had to add the URL of the plugin manually, but it worked eventually. I am using a Mac so:

Arduino > Preferences > Additional Boards Manager Urls: https://adafruit.github.io/arduino-board-index/package_adafruit_index.json

After that, I was able to find the Adafruit plugin in the boards manager pop-up window.

:)

P.S. There is a Git with the unofficial list of the 3rd party boards here: https://github.com/arduino/Arduino/wiki/Unofficial-list-of-3rd-party-boards-support-urls in case somebody may need it!