You forgot your Sketchbook

Error Message

Total newb, no clue how to fix. Yes I googled, yes I found some things, most things not relevant and others are like me trying to decipher Russian using stone tablets. How to "Path"? Read this in "Preferences" text doc that says not to change anything in said text doc.

That implies that you don't have write permissions to your own documents folder... you might want to figure out why that is.

I think DrAzzy answered the important question but just to respond to the others:

How to "Path"?

You'd need to provide more information if you want an answer to that. I'm pretty sure there was more to whatever you read than just "Path".

Read this in "Preferences" text doc that says not to change anything in said text doc.

That's the wrong file. The one you would want to edit is located at C:\Users{username}\AppData\Local\Arduino15. If you can't figure out why you can't write to your documents folder then you may be able to change the sketchbook location by editing the value of sketchbook.path in the preferences.txt file found at that location.

Same issue I think; IDE splash screen pops up, then disappears and IDE is crashed. I run as an admin on Win10.

The error log reads “you forgot your sketchbook” error msg.

I’m trying to find this preferences.txt in de Arduino15 folder, but it’s empty (not hidden either).

When I delete Arduino15 folder, it is recreated once I start the IDE.

Any ideas?

Try this:

  1. Create a file named preferences.txt in the Arduino15 folder.
  2. Open the file in a text editor.
  3. Add the line sketchbook.path= followed by the path to a folder you have created for your sketchbook.
  4. Save preferences.txt
  5. Try starting the Arduino IDE again.
1 Like

Thanks! Didn't work though..

Getting the same error msg:

"You forgot your sketchbook: Arduino cannot run because it could not
create a folder to store your sketchbook."

I have created the folder that I put as the sketchbook path. I am sure it can be written in. I start as admin. And defined the path in unix format with forward slash and win format back slash.

Any more ideas?

Do you have a folder inside your Arduino IDE installation folder named portable?


What does the IDE say under File -> Preferences -> Settings -> Sketchbook location ? Shoud be something like "C:\Users\Erik\Documents\Arduino".

The IDE doesnt start; I only get the splash screen, then the IDE disappears (i.e. also no longer in processes in task manager).

I have tried reinstalling, the nightly build and the windows application as alternatives, all with same result.

Try creating a folder named portable under the Arduino IDE installation folder to see what happens in portable mode.

Note that you won't be able to do this if the Arduino IDE is installed under your C:\Program Files or C:\Program Files (x86) folders because Windows is super restrictive of those folders. You also can't do it with the Windows App version because it doesn't even let you create a folder, to say nothing of letting the Arduino IDE modify it.

However, if you are using the "Windows ZIP file for non admin install" version of the Arduino IDE or the nightly build, then you can have the Arduino IDE installed anywhere you like and that will allow you to run in portable mode.

in de Arduino15 folder

What is the complete path to the Arduino15 folder ?

@ Eric

The path would normally be one of these.


Partly depends on the IDE version.
If you have had more than one version of the IDE it could even be both.


creating the ‘portable’ folder did the magic…

very happy!!

Thank you all for your support.

I'm glad portable mode allowed you to run the Arduino IDE. It's a shame if we can't figure out why it won't work in non-portable mode, but at least you have a workaround now to let you start having fun with Arduino, as well as proof that the Arduino IDE can work on your computer.

1 Like