Yun bricked after try to install LininoIO?


I got an Arduino Yun, and I wanted to use it to read from sensors and send the data via wifi to a node server using johnny-five.

This is the process that I have followed to install johnny-five following the instruction in nino-io:

Until here everything was Ok.

Then I followed the steps to install lininoIO:

In the YunSerialTerminal I did:

But after that, I can't access via SSH to my Yun through the "YunSerialTerminal", I can't see anything.

I have lost the Yun Password after sysupgrade and I can't recover it introducing it again through the "passwd" instruction in the "YunSerialTerminal", and consequently I can't access the yun via puTTY either.

The USB LED, never lights now, and the RX LEDis always blinking.

When I reset the Yun through the YunSerialTerminal the restart doesn't finish. I have attached the reset. With this reset I can't get failsave mode to reset the Yun to factory mode.

So I think I have bricked My Yun.

Some Idea to fix it?


YUN RESET .doc (32 KB)

You tried holding the WLAN RST for 30 seconds?

At the end I could finish the install:

  • run-avrdude /etc/linino/bathos-one.hex
  • reboot && exit

The problem was that after the "sysupgrade" the board sets the board to linino defaults for the Name = "linino" and Password = 'doghunter'. therefore I could access via ssh and finish the installation.

Now my problem is that I can't access the board via the serial port (COM), In the Arduino IDE in tools --> port --> doesn't appear.

Some Idea how to fix that?


If you can access the web interface or ssh into it, you can try uploading the unbrick_32u4 hex file linked to here. It has worked for me several times when I'd lost serial to the Yun.

It worked!!! thanks

I uploaded the Blink example such as commented Federico in the link you indicated in your post and I recovered the COM port in the Arduino IDE. Thanks again.

But I tried to upload the YunSerialTerminal example through the COM port and to access the board, but when I opened the serial monitor I can't see nothing. I don't know If it's related with the fact that I have installed LininoIO and if I have to do something to access. Also the USB LED doesn't light even though I can see the port in the IDE, and the RX LED is always blinking

Some Idea?? I'm trying to find out.


You're welcome, of course :slight_smile:

I'm afraid I haven't played with LininoIO - but I've also encountered problems with YunSerialTerminal (testing after unbricking)... for some reason I've yet to discover, the Yun seems a bit temperamental sometimes. Try the 32u4 reset button, it's worked for me.

Thanks for the reply.

It had been very nice that with 32u4 reset button the problem was solved, but no luck.

If I find a solution I’ll post it.

It sounds a bit odd that the USB light stays off but you can upload sketches?


Are there some way I can edit the /etc/inittab file, without access to the Arduino Yun via wifi, ethernet and YunSerialTerminal?

I tried to make a proof and edited the file commenting the last line:

::sysinit:/etc/init.d/rcS S boot
::shutdown:/etc/init.d/rcS K shutdown
#ttySPI0::respawn:/bin/ash --login

And now I have no wifi nor ethernet access?


Well it seems to me you've lost all avenues of access now. All I can think of is the 30 second WLAN reset. :frowning:


I tried to reset pressing the WLAN RST for at least 30 second and nothing happened.

I installed in my Yun LininoOS and LininoIO, even though LininoOS is a version of OpenWRT I don’t know if pressing at least 30 seconds works in the same way or simply by the fact of commenting the inittab file this option is lost

I tried the (failsave mode) option from U-boot.I uploaded YunSerialTerminal and press YUN RST and the result is this:

U-Boot 1.1.4-linino-g335e76c8-dirty (Mar  5 2015 - 09:56:20)

Linino Board (ar9331) U-boot
DRAM:  64 MB
Top of RAM usable for U-Boot at: 84000000
Reserving 217k for U-Boot at: 83fc8000
Reserving 192k for malloc() at: 83f98000
Reserving 44 Bytes for Board Info at: 83f97fd4
Reserving 36 Bytes for Global Data at: 83f97fb0
Reserving 128k for boot params() at: 83f77fb0
Stack Pointer at: 83f77f98
Now running in RAM - U-Boot at: 83fc8000
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16777216, sector count = 256
Flash: 16 MB
In:    serial
Out:   serial
Err:   serial
Net:   eth0: b4:21:8a:00:00:00
eth1: b4:21:8a:00:00:01
eth0, eth1
autoboot in 4 seconds (stop with 'lin')...
## Booting image at 9fea0000 ...
   Image Name:   MIPS OpenWrt Linux-3.3.8
   Created:      2015-02-03  14:03:09 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1129750 Bytes =  1.1 MB
   Load Address: 80060000
   Entry Point:  80060000
   Verifying Checksum at 0x9fea0040 ...OK
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 80060000) ...
## Giving linux memsize in bytes, 67108864

Starting kernel ...

[    0.000000] Linux version 3.3.8 (build@build-base) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #1 Tue Feb 3 15:02:42 CET 2015
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR9330 rev 1
[    0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] User-defined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone PFN ranges:
[    0.000000]   Normal   0x00000000 -> 0x00004000
[    0.000000] Movable zone start PFN for each node
[    0.000000] Early memory PFN ranges
[    0.000000]     0: 0x00000000 -> 0x00004000
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line:  console=spicons board=linino-yun mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env),14656k(rootfs),1280k(kernel),64k(nvram),64k(art),15936k@0x50000(firmware) mem=64M rootfstype=squashfs,jffs2 noinitrd rootfstype=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 61004k/65536k available (2416k kernel code, 4532k reserved, 686k data, 216k init, 0k highmem)
[    0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:256
[    0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[    0.080000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.080000] NET: Registered protocol family 16
[    0.090000] gpiochip_add: registered GPIOs 0 to 29 on device: ath79
[    0.090000] MIPS: machine is Arduino Yun
[    0.530000] mach-linino: setting GPIO
[    0.530000] Setting GPIO OE 21
[    0.540000] Setting GPIO OE2 22
[    0.540000] Setting GPIO UART-ENA 23
[    0.540000] mach-linino: enabling GPIO SPI Controller
[    0.550000] bio: create slab <bio-0> at 0
[    0.560000] Switching to clocksource MIPS
[    0.570000] NET: Registered protocol family 2
[    0.570000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.570000] TCP established hash table entries: 2048 (order: 2, 16384 bytes)
[    0.570000] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
[    0.570000] TCP: Hash tables configured (established 2048 bind 2048)
[    0.570000] TCP reno registered
[    0.570000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.580000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.580000] NET: Registered protocol family 1
[    0.600000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.600000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.610000] msgmni has been set to 119
[    0.610000] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[    0.610000] io scheduler noop registered
[    0.620000] io scheduler deadline registered (default)
[    0.620000] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.630000] ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11) is a AR933X UART
[    0.630000] console [spicons0] enabled, bootconsole disabled

As you can see I never get the option of enter failsave mode.

In other way I tried to reset pressing the WLAN RST for at least 30 second and nothing happened.

Are there another way to revive the Yun?
If it helps, I’m working over the Yun from a laptop with windows 7 x64



I got the solution by two ways: