Yun Client and Bridge Examples stopped working

Hello.

I have an Arduino Yun which I have used for a few months now through an old IDE version.
I recently updated the IDE to 1.6.8 (now downgraded to 1.6.7), and now any code that requires wifi, or includes bridge or Yun client no longer works.

Note: before updating the IDE, I used the Yun for multiple projects, including sending data over wifi.

For example, when running WiFiStatus bridge example, I only get “Starting bridge…” on the serial monitor. The Yun is connected to my home network, and is connected to my laptop through usb.

Additionally, when running my previously tested and functioning code that sends data to ThingSpeak, the code stops working when it reaches the line of updateThingSpeak(…).
Note: I tested different functions to send data to ThingSpeak and all give the same result. updateThingSpeak worked fine before updating the IDE.

Here is the general structure of my code for ThingSpeak.

#include <elapsedMillis.h>
#include <ThingSpeak.h>

#include <Bridge.h>
#include <SPI.h>
#include <YunClient.h>
  


long lastConnectionTime = 0;
boolean lastConnected = false;

YunClient client;


char thingSpeakAddress[] = "api.thingspeak.com/channels/MY CHANNEL NUMBER";

unsigned long myChannelNumber = MY CHANNEL NUMBER HERE;        
String  APIKey = "MY WRITE API KEY HERE";            
const int updateThingSpeakInterval = 300 * 1000;  

void setup() {
 Serial.begin(9600);
 ThingSpeak.begin(client);


 Bridge.begin();
 
}

void loop() {
 
while(!Serial);    
int val = 100;     // just to test sending a constant value


Serial.println(val);  

updateThingSpeak("field1=" + val);


}


void updateThingSpeak(String tsData) {
 if (client.connect(thingSpeakAddress, 80)) {
   client.print("POST /update HTTP/1.1\n");
   client.print("Host: api.thingspeak.com\n");
   client.print("Connection: close\n");
   client.print("X-THINGSPEAKAPIKEY: " + APIKey + "\n");
   client.print("Content-Type: application/x-www-form-urlencoded\n");
   client.print("Content-Length: ");
   client.print(tsData.length());
   client.print("\n\n");
   client.print(tsData);
   lastConnectionTime = millis();

   if (client.connected()) {
     Serial.println("Connecting to ThingSpeak...");
     Serial.println();
   }
 }
}

I tired multiple solutions and read most related forum posts but haven’t found a solution for my case.
Any suggestions?

Is it possible that the Linino side is dead or unresponsive?

I tried uploading the YunSerialTerminal example, and then using PuTTy.
I get a blank black page with just a green cursor that does not blink. I cant type any command.

@aliya1101,
have your tried the simple bridge example/tutorial?
Otherwise you are not giving enough information about what you have tried.

Jesse