Yun crashes when capturing a frame from webcam

Hi all,

I have a HD USB webcam (UCV) plugged into my yun through a powered USB hub (2Am).
Yun itself is powered from 1.8Am phone charger.

Camera specs: 5MP HD Wide Anagle Fisheye Lens USB Camera with YUY and MJPEF Output [ELP-USB500W02M-L170] - $0.00 : Surveillance Equipment,CCTV Systems,USB Camera Module Supplier, Best USB Cameras Module,Network IP Cameras,Analog CCTV Cameras,IP Network Video Recorders ,Digital Video Recorders,IP Network Camera Systems,Security Camera Systems,Mobile DVR Systems ,Security System Accessories,Color LCD/LED Monitor/Car Video,Wireless Tranmission Module ,Digital camera lens for building, city,airport,police,bank,shop,home and office etc.

When I attach camera it is recognised:

Apr  3 15:06:11 kern.info kernel: [  581.190000] usb 1-1.1.4.4: USB disconnect, device number 6
Apr  3 15:06:15 kern.info kernel: [  585.270000] usb 1-1.1.4.4: new high-speed USB device number 7 using ehci-platform
Apr  3 15:06:15 kern.info kernel: [  585.380000] usb 1-1.1.4.4: New USB device found, idVendor=05a3, idProduct=9520
Apr  3 15:06:15 kern.info kernel: [  585.380000] usb 1-1.1.4.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Apr  3 15:06:15 kern.info kernel: [  585.390000] usb 1-1.1.4.4: Product: HD USB Camera
Apr  3 15:06:15 kern.info kernel: [  585.390000] usb 1-1.1.4.4: Manufacturer: HD Camera Manufacturer
Apr  3 15:06:15 kern.info kernel: [  585.400000] uvcvideo: Found UVC 1.00 device HD USB Camera (05a3:9520)
Apr  3 15:06:15 kern.info kernel: [  585.530000] input: HD USB Camera as /devices/platform/ehci-platform/usb1/1-1/1-1.1/1-1.1.4/1-1.1.4.4/1-1.1.4.4:1.0/input/input2

When I try to use fswebcam with following settings:

device /dev/video0
input 0
frames 1
skip 0
fps 1
dumpframe /mnt/sda1/frame
resolution 160x120
jpeg 50
save /mnt/sda1/viewcam.jpg
palette MJPEG

I get the following:

/mnt/sda1# fswebcam -c  fswebcam.conf 
--- Opening /dev/video0...
Trying source module v4l2...
/dev/video0 opened.
Adjusting resolution from 160x120 to 320x240.
--- Capturing frame...
packet_write_wait: Connection to 192.168.178.59 port 22: Broken pipe

After that Yun is just rebooting without any output in syslog.
Is it something with the camera? It works with my notebook.
Could someone advise me how to make it work?

Thanks