Yun dns lookup fail

Hi there, after configuring my Yun through this IP http://192.168.240.1/ and filling in my wifi settings, I have been unable to get to my http://arduinojoan.local/ page. I followed the advice on from this forum thread http://forum.arduino.cc/index.php?topic=202004.0 ..yet I am still having problems. When I type ifconfig into the serial monitor for the YunSerialTerminal sketch, in the wlan0 section there is no inet address. This is what I see in my serial monitor: root@ArduinoJoan:/# cat /etc/config/wireless |grep disabled option disabled '0' root@ArduinoJoan:/# ifconfig eth1 Link encap:Ethernet HWaddr 90:A2:DA:F8:3B:3D UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) Interrupt:4

lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:5376 errors:0 dropped:0 overruns:0 frame:0 TX packets:5376 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:365568 (357.0 KiB) TX bytes:365568 (357.0 KiB)

wlan0 Link encap:Ethernet HWaddr 90:A2:DA:F0:3B:3D UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:104 errors:0 dropped:0 overruns:0 frame:0 TX packets:104 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:11752 (11.4 KiB) TX bytes:16328 (15.9 KiB)

..furthermore, when I type this into the monitor: avahi-browse -a & , I get nothing back.

If anyone has any advice on this it would be much appreciated! thanks

It looks like your yun is not connecting to your network.

What do you see if you:

root@Arduino:/# uci show wireless
wireless.radio0=wifi-device
wireless.radio0.type=mac80211
wireless.radio0.hwmode=11ng
wireless.radio0.path=platform/ar933x_wmac
wireless.radio0.htmode=HT20
wireless.radio0.ht_capab=SHORT-GI-20 SHORT-GI-40 RX-STBC1 DSSS_CCK-40
wireless.radio0.disabled=0
wireless.radio0.channel=auto
wireless.radio0.country=US
wireless.@wifi-iface[0]=wifi-iface
wireless.@wifi-iface[0].device=radio0
wireless.@wifi-iface[0].network=lan
wireless.@wifi-iface[0].mode=sta
wireless.@wifi-iface[0].ssid=yyyyyyyyy
wireless.@wifi-iface[0].encryption=psk2
wireless.@wifi-iface[0].key=xxxxxxxxxxx

?

The avahi on the yun only broadcasts doesn't scan. If you are running linux on your host then avahi-browse will find the yun once you get it connected to the network. If you are running windows you will need to use something like http://hobbyistsoftware.com/bonjourbrowser

as a side note I have noticed that sometimes on one small wifi antenna of mine the avahi/bonjour protocol was not set up and broadcasted.. just didn't work. When I used an openwrt old router.. works nice.

anyway, if you run the Process example ( http://arduino.cc/en/Tutorial/Process ) you manage to get the curl result?