Yun linux enviroment is dead. [SOLVED]

Find attached the info.
I know what is the problem I uninstalled the gpio-keys-polled package… that generates a kernel panic??? May be. It’s there a way to reinstall …

I tried to press f when the console suggest, without success I’ve this other message:

Press the [f] key and hit [enter] to enter failsafe mode
f- regular preinit -
[ 9.910000] jffs2: notice: (528) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 53 of xref (0 dead, 0 orphan) found.

  • merge overlay components -
    [ 10.060000] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000200
    [ 10.060000]

I can hit other key at start and I can achieve the prompt. May be this can be the way for install package…

I arrived to:

ar7240> help

? - alias for ‘help’
boot - boot default, i.e., run ‘bootcmd’
bootd - boot default, i.e., run ‘bootcmd’
bootm - boot application image from memory
cp - memory copy
erase - erase FLASH memory
help - print online help
md - memory display
mm - memory modify (auto-incrementing)
mtest - simple RAM test
mw - memory write (fill)
nm - memory modify (constant address)
ping - send ICMP ECHO_REQUEST to network host
printenv- print environment variables
progmac - Set ethernet MAC addresses
reset - Perform RESET of the CPU
run - run commands in an environment variable
setenv - set environment variables
tftpboot- boot image via network using TFTP protocol
version - print monitor version
ar7240>

I await for suggestions.

yun_start_up.txt (9.3 KB)

The last stuff you posted is the bootloader, don't want to mess around there unless you have to, you probably got that one when it is counting down from 4 to 0.

Before you press the reset by the leds open the serial monitor and type f in the box at the top to right of the send button, don't do anything else in the serial monitor.

Now press the reset by the leds, move your mouse to the send button, wait for the "Press the [f] key and hit [enter] to enter failsafe mode" prompt then press send in the serial monitor. You should go into failsafe at that point.

What OS are you running on your computer? Do you have a terminal set up to connect to the Arduino? In linux it may be something like picocom or minicom, Windows people usually use PuTTY. It makes things easier than working with the serial monitor and that !@#$%^ send button!

Ok. I’ll proced as you said. I use linux. When I get controll I’ll try to rei.stall package…

I’ll be away for a few but while I walk the dogs, install picocom, start it with:

picocom -b 115200 /dev/ttyACM0

If you are not on Ubuntu it may need something different from ttyACM0, you can find it in the Tools->Port menu of the IDE.
Start picocom before you press the reset, then you can just type f and in picocom instead of using the Send button.
When you get to the failsafe prompt, try mount_root, see if the kernel panics.

I'll go out too for a while. Thanks.

I wasn’t sure if this was the right thingtm but I went ahead and tried it to be the guinea pig.

If you get to the failsafe prompt, run firstboot and tell it yes you are sure, don’t bother with mount_root. When it finishes (it takes a while) you will see a message to reboot. Push the reset button again and when it boots up the Linino side should be back where it was when you took the Yun out of the box.

Good Luck

I've finished the process with success.

When I launched the firsboot command I don't get the Reboot message. I've tryed with the command: root@(none):/usr/bin# ./reset-to-factory-anyway (This info I got from linino sources in yun-scripts folder). The systems reboots and I get the same errors, but starts. I can see the YUN wifi and get controll. Now it seems works ok.

Thanks you very much.

I confirm all is working OK.

Glad to hear you are back on the road.

The reset-to-factory-anyway script looks like it runs firstboot and does a few other things, it is probably the best way to go if anyone else gets in this situation.

Hi,

I thought I would add a reply in this thread since here the problem was solved. I am having similar problems where the blue wlan LED does not flash when pressing the 'wlan reset' button.

I tried the YunSerialTerminal sketch, pressed the 'wlan reset' button and got the following response:

U-Boot 1.1.4-gd995931a-dirty (Aug  7 2013 - 16:16:04)

Arduino Yun (ar9331) U-boot

DRAM:  64 MB
Top of RAM usable for U-Boot at: 84000000
Reserving 142k for U-Boot at: 83fdc000
Reserving 192k for malloc() at: 83fac000
Reserving 44 Bytes for Board Info at: 83fabfd4
Reserving 36 Bytes for Global Data at: 83fabfb0
Reserving 128k for boot params() at: 83f8bfb0
Stack Pointer at: 83f8bf98
Now running in RAM - U-Boot at: 83fdc000
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16777216, sector count = 256
Flash: 16 MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag7240_enet_initialize...
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
: cfg1 0x5 cfg2 0x7114
eth0: 00:03:7f:09:0b:ad
eth0 up
: cfg1 0xf cfg2 0x7214
eth1: 00:03:7f:09:0b:ad
athrs26_reg_init_lan
ATHRS26: resetting s26
ATHRS26: s26 reset done
eth1 up
eth0, eth1
Hit any key to stop autoboot:  4  3  2  1  0 
## Booting image at 9fea0000 ...
   Image Name:   MIPS OpenWrt Linux-3.8.3
   Created:      2013-08-19  14:23:28 UTC
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1170186 Bytes =  1.1 MB
   Load Address: 80060000
   Entry Point:  80060000
   Verifying Checksum at 0x9fea0040 ...Bad Data CRC
ar7240>

Any ideas on how to proceed?

What was the last thing you do before it stopped working? Did you update the system image?

Please upload the YunSerialTerminal, open the serial monitor and press the YUN RST button instead of the wlan reset one. Post the output here.

Sorry, I meant to say that is the output from pressing the YUN RST button, got my terms muddled up when typing there.

Also, I don't know what was the last thing I was doing, nothing like updating the system image, just haven't used it in a while, its just been sitting in its box for around 6 months...

WillBrown, I have the same exact issue and I have posted it here.

Feel free to move your comments over there. Looks like our Kernel images are toast. I'm waiting for some more official feedback before I continue, but it seems that the only option left is to reflash them.

mrshadow: WillBrown, I have the same exact issue and I have posted it here.

Feel free to move your comments over there. Looks like our Kernel images are toast. I'm waiting for some more official feedback before I continue, but it seems that the only option left is to reflash them.

Many thanks @mrshadow

I was able to reflash my Kernel and OpenWrt, but unfortunately, I'm still have some issues with the SysUpgrade 16MB image.

We shall see.

I tried understanding what you have done but it might take a bit of rereading. In any case, I will follow what you are doing. Just to clarify however, you need a micro SD card to do this? Not exactly something I have to hand unfortunately...

WillBrown, I formatted my SD card with SD Formatter and copied the .bin file onto the SD card.

You’ll still have to flash the Kernel and the OpenWRT, but looks like I’m set.

Great, thanks for leading the way! I have ordered a micro SD card and then I guess I will give it a go. May ask further questions when I get there depending on how I get on

Use the "SD Formatter" tool that is out there. I don't know what/if anything was wrong with mine, but that seemed to solve it for me. I haven't tried to flash it all again a second time to "check".