Yun not Compiling Using Mac 10.7 OS and Arduino IDE 1.8.1

I currently have a new Yun and have gone through with the downloading of the IDE and updating drivers. The Yun is set up with wifi and I can connect to it via Web. I am trying to compile the blink program and it is jus saying this;

Arduino: 1.8.1 (Mac OS X), Board: “Arduino Yún”

/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/…/lib/gcc/avr/4.9.2/…/…/…/…/avr/bin/ar: dlopen(/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/…/libexec/gcc/avr/4.9.2/liblto_plugin.so, 2): Symbol not found: _environ
Referenced from: /Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/…/libexec/gcc/avr/4.9.2/liblto_plugin.so
Expected in: /usr/lib/libSystem.B.dylib

/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/…/lib/gcc/avr/4.9.2/…/…/…/…/avr/bin/ar: dlopen(/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/…/libexec/gcc/avr/4.9.2/liblto_plugin.so, 2): Symbol not found: _environ
Referenced from: /Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/…/libexec/gcc/avr/4.9.2/liblto_plugin.so
Expected in: /usr/lib/libSystem.B.dylib

/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/…/libexec/gcc/avr/4.9.2/liblto_plugin.so, 2): Symbol not found: _environ
Referenced from: /Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/…/libexec/gcc/avr/4.9.2/liblto_plugin.so
Expected in: /usr/lib/libSystem.B.dylib

collect2: error: ld returned 1 exit status
exit status 1
Error compiling for board Arduino Yún.

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.