Yun- root password?

Followed “Guide to the Arduino Yun”:
Installed the Window IDE OK
Configured the onboard WiFi OK
Yun board configuration OK (All password are the same, easy to remember)
(powered down/up Yun board)
Programed the 32U4 over WiFi (Blink sketch) OK

Communicating with Linino via bridge loaded Console sketch
Loaded windows PUTTY
was able to ping
typed “ssh root@” response was enter password for root
the password entered in Yun configuration (wirenut) NG
response: requested password for root
“arduino” same result NG
upon password request same result NG


So the problem is that you've lost your password?
Two workarounds:

  • start the yun and wait a minute, load the yunserialterminal example, open the serial monitor, press enter and see the prompt, type "passwd" without the double quotes and change your password
  • start the yun and wait a minute, the press and hold the reset button for about 40 seconds (it's on the side, near the USB connector)

I had lost my password too.

I tried what Federico suggested.

  1. Burn the YunSerialTerminal onto the Yun
  2. Run the serial terminal (be sure to set the correct baud rate)
  3. Change the Line endings option on the serial monitor to ( New Line)
  4. Type "passwd" , enter your password twice.
  5. Rejoice :wink: