Yun suddenly will not upload sketches

Hi Everyone,

I'm new to working with the Yun and Arduino in general, but not to software development or controls. I was very interested in the Yun as a flexible card we might be able to use on a few jobs that needed something off the normal menu to please a client.

So, I picked a couple up, configured the wifi easily, updated Linino and set to work added sensors. But when I went from basic stuff like talking to a temp humidity sensor on A0, to adding an OLED display form Seeed on I2C, I was unable to upload anything further.

I get this error:

[color=black]Sketch uses 5,132 bytes (17%) of program storage space. Maximum is 28,672 bytes.
Global variables use 153 bytes (5%) of dynamic memory, leaving 2,407 bytes for local variables. Maximum is 2,560 bytes.[/color]
[color=red] ***failed;  
avrdude: verification error, first mismatch at byte 0x0000
         0xcb != 0xfb
avrdude: verification error; content mismatch[/color]

And that's trying to load back the "Blink" example or just an empty sketch.

Here's the interesting bit: I can ssh into the Linino side without a problem. It is fully functional as far as I can tell.

I tried to connect the board via usb to burn a new bootloader, but it is not recognised by usb. I thought perhaps I was having usb issues at first, but plugging in anything else, including a Arduino clone called the Xadow, pop right up. The board is just not talking to anyone anymore from the Arduino side.

Is there a way to rebuild the Arduino side of the bridge from Linino?

Is there a way to reset the sketch loaded in the Yun to the default empty sketch either with a button on the board or via Linino?

Any and all advice welcome.

I really don't want to report back to work that the Yun is a board you can brick with a few lines of code, but in my ignorance of how it works it seems I've managed to do so... The scary thing is I was just pulling together example code. It was literally the DHT22 on A0 plus an OLED display on I2C. I also had a Red Bear Labs BLE 4.0 shield on the card, but I was not using it in code. It only uses two pins and they were free.

Relevant links...

BLE shield: http://redbearlab.com/bleshield/

OLED Display: http://www.seeedstudio.com/wiki/Grove_-_OLED_Display_128*64

Temp/Humidity Sensor: http://www.seeedstudio.com/wiki/Grove_-_Temperature_and_Humidity_Sensor_Pro

Kind regards,

-R.

Did you try to upload a sketch via LAN ?

I once had the problem that the bootloader disappeared, which gave the same symptons as you describe. I reburned the bootloader using Arduino as ISP.

But i think there might be easyer solutions, I think it would be better asking in the Yun subforum

Thanks, Erni.

I'll post the same question over there, as you suggested, and see if I get more of a response.

I'm not sure what "Arduino as ISP" means, but I'll search the forum for instructions on doing that--sounds promising!

I can't get it to show up on usb, can you burn a bootloader via ethernet? I did try to upload a sketch using the ethernet connection and it gave that same result.

I’m not sure what “Arduino as ISP” means

It means you use an Arduino withe the sketch ArduinoISP ,as a programmer,

Take a look at this.

http://www.gammon.com.au/forum/?id=11643