YUN WAN not working after restore at failsafe

Interesting situation that really has me scratching my head! Upgraded to new Openwrt load for YUN. WAN and LAN worked fine with either connection before and after upgrade. Tried a couple of configurations to play with forwarding and a couple of other things. Didn't like the way things worked so rebooted and went to failsafe then did the restore to initial configuration. Worked fine as far as I could tell. Got back in via Luci with WAN and LAN both connecting to the router. Configured static addresses for both, both use same gateway, and put in DNS servers. Was able to load all packages fine.

Now here's the strange thing. As long as the ethernet wire is plugged in I can get to Luci or use SSH to connect to either the LAN or the WAN. But if I disconnect ethernet nothing works on WAN. WAN shows up fine with proper static address on the router. Neither SSH or LUCI will connect to the proper WAN IP. It's interesting to note that yun.local doesn't work either - I have to enter the actual IP. So something is hosed up in the YUN that it won't allow connections.

Any thoughts on what's wrong or how to get WAN working without the ethernet cable plugged in?

Found the problem. It appears that the restore didn't actually take everything back to original. I'm sure the files were restored but I'm betting that something was left that fouled up the defaults since I was using both interfaces in playing around before I did the restore.

Anyway, using Luci I was able to find that the WAN interface had to be set properly for sharing both WAN and LAN on the on wireless. Once that was done then wireless worked fine both both.

If you run in such issues in the future and can access the yun through YunSerialTerminal, type

reset-to-factory-anyway && reboot

This will bring your yun back to the moment right after your last upgrade