Yun wireless (lan) fails when eth1 (wan) is disconnected

Arduino Yun is working fine. I can load scripts over either network. Both have a unique static IP configured for my private network.
So now I want to go completely wireless. If I unplug the ethernet cable from the YUN the wireles port (lan) goes down. With the ethernet connected I can ping both IP addresses, run the arduino YUN setup page over either port. I have read through the configuration settings. I know I am missing something.

LAN (wireless) settings from /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11ng'
option path 'platform/ar933x_wmac'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option channel 'auto'
option country 'US'

config wifi-iface
option device 'radio0'
option mode 'sta'
option ssid 'zzzzzzz'
option encryption 'psk2'
option key 'xxxxxxxxxxx'
option network 'lan'

/etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option _orig_ifname 'wlan0'
option _orig_bridge 'false'
option proto 'static'
option ipaddr '192.168.169.238'
option netmask '255.255.255.0'
option gateway '192.168.169.254'
option broadcast '192.168.169.255'

config interface 'wan'
option _orig_ifname 'eth1'
option _orig_bridge 'false'
option proto 'static'
option ipaddr '192.168.169.239'
option netmask '255.255.255.0'
option gateway '192.168.169.254'
option broadcast '192.168.169.255'
option ifname 'eth1'

So I owe an update on this issue. The simple answer is - KEEP IT SIMPLE. I reset the linino with a +30 second press of the wifi button and no ethernet cable plugged in. Then Joined the the arduino network per the instructions, and then followed the instuctions. Bottom line is - don't get fancy with it. I am sure all my messing around confused the poor thing. I now have a wireless YUN. Just for reference:

/etc/config/network looks like this now - which is basically off.

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option proto 'dhcp'

config interface 'wan'
option ifname 'eth1'
option proto 'dhcp'
option metric '10'

and /etc/config/wireless is now like this

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11ng'
option path 'platform/ar933x_wmac'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option channel 'auto'
option country '00'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'sta'
option ssid 'xxxxxxxxx'
option encryption 'psk2'
option key 'xxxxxxxxxxx'