3dprintersarehard

mymarlinsoftware is having this error
Arduino: 1.6.6 (Windows 7), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

In file included from sketch\Marlin.h:22:0,

from sketch\BlinkM.cpp:5:

sketch\Configuration.h:238:0: warning: “Y2_STEP_PIN” redefined [enabled by default]

#define Y2_STEP_PIN ORIG_E1_STEP_PIN

^

In file included from sketch\Configuration.h:42:0,

from sketch\Marlin.h:22,

from sketch\BlinkM.cpp:5:

sketch\pins.h:614:0: note: this is the location of the previous definition

#define Y2_STEP_PIN 36

^

In file included from sketch\Marlin.h:22:0,

from sketch\BlinkM.cpp:5:

sketch\Configuration.h:239:0: warning: “Y2_DIR_PIN” redefined [enabled by default]

#define Y2_DIR_PIN ORIG_E1_DIR_PIN

^

In file included from sketch\Configuration.h:42:0,

from sketch\Marlin.h:22,

from sketch\BlinkM.cpp:5:

sketch\pins.h:615:0: note: this is the location of the previous definition

#define Y2_DIR_PIN 34

^

In file included from sketch\Marlin.h:22:0,

from sketch\BlinkM.cpp:5:

sketch\Configuration.h:240:0: warning: “Y2_ENABLE_PIN” redefined [enabled by default]

#define Y2_ENABLE_PIN E1_ENABLE_PIN

^

In file included from sketch\Configuration.h:42:0,

from sketch\Marlin.h:22,

from sketch\BlinkM.cpp:5:

sketch\pins.h:616:0: note: this is the location of the previous definition

#define Y2_ENABLE_PIN 30

^

In file included from sketch\Marlin.h:22:0,

from sketch\BlinkM.cpp:5:

sketch\Configuration.h:242:0: warning: “Z2_STEP_PIN” redefined [enabled by default]

#define Z2_STEP_PIN ORIG_E1_STEP_PIN

^

In file included from sketch\Configuration.h:42:0,

from sketch\Marlin.h:22,

from sketch\BlinkM.cpp:5:

sketch\pins.h:618:0: note: this is the location of the previous definition

#define Z2_STEP_PIN 36

^

In file included from sketch\Marlin.h:22:0,

from sketch\BlinkM.cpp:5:

sketch\Configuration.h:243:0: warning: “Z2_DIR_PIN” redefined [enabled by default]

#define Z2_DIR_PIN ORIG_E1_DIR_PIN

^

In file included from sketch\Configuration.h:42:0,

from sketch\Marlin.h:22,

from sketch\BlinkM.cpp:5:

sketch\pins.h:619:0: note: this is the location of the previous definition

#define Z2_DIR_PIN 34

^

In file included from sketch\Marlin.h:22:0,

from sketch\BlinkM.cpp:5:

sketch\Configuration.h:244:0: warning: “Z2_ENABLE_PIN” redefined [enabled by default]

#define Z2_ENABLE_PIN E1_ENABLE_PIN

^

In file included from sketch\Configuration.h:42:0,

from sketch\Marlin.h:22,

from sketch\BlinkM.cpp:5:

sketch\pins.h:620:0: note: this is the location of the previous definition

#define Z2_ENABLE_PIN 30

^

In file included from sketch\BlinkM.cpp:5:0:

Marlin.h:212: error: ‘EXTRUDERS’ was not declared in this scope

extern int extruder_multiply[EXTRUDERS]; // sets extrude multiply factor (in percent) for each extruder individually

^

Marlin.h:213: error: ‘EXTRUDERS’ was not declared in this scope

extern float volumetric_multiplier[EXTRUDERS]; // reciprocal of cross-sectional area of filament (in square millimeters), stored this way to reduce computational burden in planner

^

Marlin.h:214: error: ‘NUM_AXIS’ was not declared in this scope

extern float current_position[NUM_AXIS] ;

^

exit status 1
‘EXTRUDERS’ was not declared in this scope

This report would have more information with
“Show verbose output during compilation”
enabled in File > Preferences.

Marlin.ino (1.83 KB)

you will probably have better luck over at the reprap forums since this is a specific problem about 3D printing software, not an Arduino issue

http://forums.reprap.org

personally, I think you might be missing some of the library files

ok thank you