A6 mini GPS/GPRS module always send NULL characters

Dear All,

I can not wake up the communication with my A6 mini gsm/gprs module. Does anybody know how is it working in fact?

5volt, GND, URX and UTX legs ware connected and the SIM card is valid, but only the NULL character was received. On the A6 board the red led is lighting continously and the blue led is blinking during the NULL character sending.

If somebody tried this type of board send me recommendation please.

Many thanks!

blue indicator is blinking at first and then it stop from blinking,Serial monitor also displays nothing so how could we solve this error?

Currently the gsm module can communicate with the arduino nano.

char incomingByte = “0000”;

void setup(){

Serial.begin(9600);

}

void loop(){

long incomingByte = 0;

if (Serial.available() > 3) {

incomingByte = Serial.read();

if (incomingByte = ‘RING’){

digitalWrite(13,HIGH);
delay(1000);
digitalWrite(10,HIGH);
delay(1000);
digitalWrite(13,LOW);
delay(1000);
digitalWrite(10,LOW);

}
else incomingByte = 0;
}

}

Problem is state by the ringtone handling now.

Dear all
I purchased arduino UNO and gsm/gprs A6 mini ,and i want to check it weather it is work or not. I am trying following code for call to my friends number but nothing happened. red led of gsm A6 mini is glow continuously. I connected rx of uno to urx of A6 gsm mini and tx of uno to urx of A6 mini ,both ground connected each other, and pwr pin of A6 mini is connected to 5 volt.and vc connected to 3.3. volt.

serial monitor show that arduino send at commands properly but no response from gsm mini.
one confusion is that i give 3 volt to the vcc pin of A6 mini.Is it right or should i give 5 volt to vcc of gsm A6 mini?
please help me.
I used this program

#include <GSM.h>
char phone_no=“032xxxxxxxx”;

void setup()
{
Serial.begin(9600);
delay(200);
Serial.println(“AT”);
delay(1000);
Serial.print(“ATD”);
Serial.println(phone_no);
//Serial.println(";");
delay(20000);
Serial.println(“ATH”);

}
void loop()
{

}

Hello,

first check my circuit for the nano-A6 min gsm module solution please. A6 mini module is working with +5V DC. Please also check and be ensure that rx-tx, urx-utx pins are in right connection.
After the power on, the A6 mini gsm module need few seconds to boot, and make connection with the mobile network. Normally after power on the red led is lighting, and after few seconds the blue led is blinking.

Try to use this code:

char incomingByte = “0000”;

void setup(){

Serial.begin(9600);

}
void loop(){

Serial.println(“ATD032xxxxxxxxxx;+ENTER”);
delay(10000);
Serial.println(“ATH”);

}