[Aide] Probleme LCD20x4 2004A

Yop Les Arduinuistes !

Nouveau sur le forum , je dirais même nouveau dans l'univers Arduino

J'en appelle a votre aide ! ;D je vous explique ..

Ayant récupérer une source pour un projet d'un de prises contrôlés pour jardin automatisé .
je me mets en marche pour reproduire , toute la prog et tout l’électronique..
Ayant tout fini je mets en route l'arduino , l'écran s'éclaire mais rien ne s'affiche ...

Je suis connecter sur 6 pin de l'écran et le 5v et gnd le tuto ne passe par la sortie I2C ... j'ai tenté au vu que la première solution ne marchait pas mais toujours le résultat et le même .

Suite a vos réponse je pourrais fournir des photos ou la source du code même

en vous remerciant , bonne soirée

bonsoir

Tu devrais lire le tuto d'Eskimon sur les LCD Redirection vers Votre premier texte sur le LCD !

Yop ETG59 !

Merci de la réponse rapide !

effectivement je vais essayer la partie du code …

#include <LiquidCrystal.h> //on inclut la librairie
 
// initialise l'écran avec les bonnes broches
 
// ATTENTION, REMPLACER LES NOMBRES PAR VOS BRANCHEMENTS À VOUS !
 
LiquidCrystal lcd(8,9,4,5,6,7);
 
void setup() {
   lcd.begin(16, 2);
   lcd.print("Salut les Zer0s!");
}
 
void loop() {

pour voir si dans un premier temp sa s’affiche sinon je changerais de LCD
Encore merci !

Edit , toujours pas de soluce ... la réponse de @EGT59 n'as pas marché pour moi .

j'ai essayé de connecter simplement un autre LCD mais cette fois 16x2 mon résultat est le même
Je sais que celui la de I2C marche , je l'utilisais sur raspberry ..

Si quelqu'un as déjà eu le même problème et serait m’éclairer j'en serais ravi !

Pour info : Les codes les plus basique basiques ne fonctionne pas , j'ai changé les lib LiquideCrystal et LiquideCrystal_I2C , tenté des modif du code , tenté d'autre PIN que le A4 , A5 vu sur la plupart des tutos

testés un 20x4 et 16x2 mais sur des cartes type elegoo uno r3 et elegoo mega2560 r3 ( cela viendrait il des cartes ? )

Quelles cartes utilises tu ?

As tu essayé tes lcd sur d'autres cartes avec le même code ?

Quand tu dis

l'écran s'éclaire mais rien ne s'affiche ...

As tu regardé du côté réglage de contraste ?

hello

j'ai relu deux fois ton fil et pas moyen de fixer les choses.

ça part dans tous les sens.

tu as testé quoi?

un LCD en parallèle ou un LCD en I2C ?

avec quel code?

si LCD en I2C as tu passé un scan I2C pour avoir l'adresse de ton afficheur?