Arduino 2560 Problem


I have 8 Mega 2650's

When i upload my code to them five work perfectly.
three of them show a statement which is placed in a different progmem space.
During the boot i print logging to the Serialport and the LCD screen these logging which are also stored in program memory contains pretty long strings
2 of them show the same message. the other a different one.
all three show only a part of the different line.
i uploaded the other 5 again to be sure it wasn't my fault due to an error in my code but these keep working as expected.

when i upload an older smaller version of the code. with less progmem variabels i do not have the issue.

As far as i can see the mega's looks the same. i verified the numbers on the chips.
is there an option to show, download or detect the bootloader versions.
because i think the difference is in there.

or someone has a better idea where to find the issue.

Kind regards


NickGammon's program might show the installed bootloader.

If nothing else, you can use it to ensure all boards have the same bootloader.

I verified the output of the different arduino's
everything is the same execpt

Arduino 1 = Lock byte = CF
Arduino 2 = Lock byte = FF
Arduino 3 = Lock byte = FF
Arduino 4 = Lock byte = FF

Arduino 1 = Clock calibration = 59
Arduino 2 = Clock calibration = 90
Arduino 3 = Clock calibration = AA
Arduino 4 = Clock calibration = 8F

Are they connected to the correct port number for each? It's probably very easy to mix up port numbers with 8 different boards!

I have 8 devices all for different customers. they should be all the same.
and all have the same program.
so i don't understand what you mean with are the connected to the correct port

Your question kind of gave the impression you were connecting all 8 to your PC at once, so each would have a different COM port.

You seem to only connect one a time.

Have you tried NickGammon's programmer to make sure they are all bootloaded the same and have the same fuse settings?

Yes i did. I verified all the settings and only the clock and lockbyte were different.
I changed the lockbyte of the not working one's but without any luck

Kind regards


when i upload a new bootloader with the nick gammon bootloader. and verify it it looks oke.
when i upload my program the bootloader verify tool notice about 3000 errors.

is that because i write a lot of progmemory or because a program is loaded.


I finally found it.
It was a realy stuppid misstake.

I read in my code the language value from the eeprom.
But because this where new arduinos the value was default so not 0 1 or 2
because i didn't check the value i read the code requested a complete wrong progmem value.


Glad you got it solved.