Arduino and Pure Data (PD) noob help?

Hey people. I am very new to both arduino and this forum of yours. I have an arduino board though, and I was planning to use it with PD, i spent several days this easter trying to get it to work, but I couldn't... I got the arduino board itself to work, but could not connect it succsessfully to PD and get values from it... If i remember right i got a RX/TX error of some sort in the end... I think i installed all the neccesary firmware and such, but still, no luck. Have there been any progress on this lately? Cause i searched a lot for relevant info when trying to get this to work, but couldn't find much... Any help is greatly appreciated. I'll hook up my board again in the next of days to give it another shot, hope someone here can be of help so I finally can start having fun with this thing... :)

do you want to exchange data between your arduino and the serial port ? check this out http://www.arduino.cc/playground/Interfacing/PD

i havent tried interfacing arduino with PD yet but using the simple message system liberary i have no problems wit interfacing it with max/msp or processing.

Hey! Thanks for your reply. I basically only want to get sensor data from arduino, and use it in PD... I have been on that page several times, downloaded all of the stuff there and tried it out in various failed attempts.... What i get is;

"Write error, maybe TX-OVERRUNS on serial line"

when i use the arduino2pd patch, with the simple message system apparently up an running...

tried the "arduino sensor concole" but dont get anything...

when using pduino 0.3 and open the arduino.pd patch i get;

"hardware: can't load library in C:/Programfiler/pd blahsymbol: hardware flatspace: can't load library in C:/Programfiler/pd blahsymbol: flatspace iemlib: can't load library in C:/Programfiler/pd blahsymbol: iemlib mapping: can't load library in C:/Programfiler/pd blahsymbol: mapping bytemask ----- ... couldn't create bytemask --------- ... couldn't create mapping/tolist ... couldn't create mapping/debytemask ... couldn't create mapping/debytemask ... couldn't create comport - PD external for unix/windows LGPL 1998-2005, Winfried Ritsch and others (see LICENCE.txt) Institute for Electronic Music - Graz Opened serial line device COM1"

Anyone got a clue? :-?

you need to use the PD extended build that contains a lot of extra libraries not found in the standard distribution

they are available from the PD website

remember to install it properly by intalling the reg file (windows) or the plist file (mac)

it works well for me

massimo

Hey, thanks. I have the extended installed though… perhaps i should try to reinstall.

Hej,

if you are running windows, I have noticed that the comport object from the extended version is not working. It feels like someone has rolled-back the code and all we get is nothingness.

Get this file:

http://webzone.k3.mah.se/projects/arduino-workshop/upload/download.asp?file=60526202904160&enc=False&lang=english

uncompress it and substitute the comport.dll in your extras folder. It will work like a charm. Btw, if you comport is over COM9 you should go into the USB-Serial settings --> Advanced and modify the number to be maximum COM8. Don't worry too much if it claims that the port is in use ... it never is.

On the other hand, the way to use this is to create a PD object called comport with two parameters:

  • the COM port number minus one: if you have COM7, the parameter will be 6
  • the port's speed

Thus, your patch could look almost like this:

Good luck,

/d

Uoops,

forgot to say ... once this works, Firmata (aka Pduino) should also work.

/d

Thank you sooo much! Tack! Took me quite some time to figure out that the [comport] external was broken...

The Firmata doesnt compile in the Arduino IDE, but ill just make some PD-hack for this right now :)