Arduino atmega 8 not anymore detected

Hey, I am new to micro controllers, brought a simple arduino atmega 8 and installed the Arduino IDE given by this site, programmed it several times, but, after i re-installed my windows it is no more detected, and computer says no device driver, however i have installed the drivers through Arduino IDE as i did it before, i also tried to update driver and force install by DRIVERS directory but still it says "windows cant find the driver. . Tried everything i could now just losing hope =( Please help... !!

(deleted)

Its USB,but I don’t know exact model, i borrowed it from a friend.
But, it has a atmega 8A-PU chip. I am attaching a image of it with this reply.
It worked earlier in windows 7.

arduino.JPG

(deleted)

On the chip next to usb is written
PL-2303HX
LF130819A
And i have downloaded the arduino software from this website only in the download section version 1.0.5
sorry about the jumper,but i didn’t have one, but this one didn’t caused any problem i guess because i was successfully uploading and working until I re-installed windows.
It only says device driver not found.

Capture2.JPG

Capture3.JPG

And one thing i do wanna tell, a program which I had uploaded earlier, still works on it when power supplied directly via battery, and i use Windows 7 ultimate

(deleted)