Arduino IDE and Eclipse (java) on AMD64 linux

I know that many of us have been struggling with java-rxtx on linux distros (Ubuntu, OpenSuSE, etc) over AMD64, in attempting to develop interfaces to the Arduino board using java (Netbeans, Eclipse etc). Or just have the Arduino IDE working properly (including the Monitor without console workarounds).

The solution is spread on different topics on the forum. Please put up with me this time and allow me to put together this information since I have seen too many friends having this very common problem. I also spent so many days looking for a solution and just got it solved. So, here it is:

you have a linux distro over AMD64? then:

Download the rxtx but NOT the version 2.1.7.
If you installed the java-rxtx from your repositories, check the version. It is likely to be the 2.1.7 (common problem for Ubuntu and OpenSuSE). Instead, download the 2.2pre2 version or higher (this is the highest at the moment of writing this post).
No problem, here is the link for the binary:

Now decompress the zip file, and you have to find only two files... there are versions for several OSs so choose the right one as follows: (under the folder ./x86_64-unknown-linux-gnu)
RXTXcomm.jar (just on the main folder, aside the README)

These two files are all you need. We will copy them as it follows:

Arduino IDE
No talking to Arduino board? or it uploads but crashes when attempting to use the monitor?
Well, then just copy (accepting to replace the files) your two files to the folder ./arduino-0016/lib
After this, I got Arduino IDE (over OpenSuSE 11.1 and AMD64) working as a charm. Including its monitor!
Notes: I used the arduino-0016 for 32 (there is no 64 version yet) but this version had no problem on AMD64. Also this should work for other distros since the version of the java-rxtx used by most repositories is the problem.
Below is a more elegant way to solve it, but just copying these two files solves the Arduino IDE problems.

for Eclipe, Netbeans and similar applications to create java interfaces
Again our two files are the solution. One way is to include them directly on the folder of your java project. As under Eclipse on the properties of your project/Build Path/ add external resources/ and selecting your RXRXcomm.jar file similar case using NetBeans.
However this is not enough. Even if you include also the at least to me, it did not make it to work.
We need to install this second file in the right place. Or both files in their right places...
In my case, using the file manager (as root), I copied this file under ./usr/lib and did link to if from ./usr/lib64
And the RXTXcomm.jar file I copied it to ./usr/share/java/
As this is the default java folder under OpenSuSE regardless of the installed Sun Java version. For other distros I guess it can be just under java-1.7.0 or whatever is your java version.

With this, you can test your connection with he Arduino board, using java as it is directed in this excellent post (this link should be on the Playground):

I tested it also under Eclipse and it works perfectly.
Finally I will be able to develop my java API to control Arduino. :smiley:

Kinds regards,

Thanks a lot Gian! I have been struggling with this all evening. Using 2.2pre2 instead of 2.1-7 solved my problem.

For ubuntu there is a ppa with everything you need.

I installed it some months ago, and didn't have any problems. From some message lists I read that they solved the rxtx issues shortly before I installed them.