Arduino is not showing in the proteus

Hi Guys!

I am stuck in a problem that I am going to install the arduino library in proteus in my desktop to simply simulate this platform in proteus design suite 8. Unfortunately, when I search in proteus I cannot see the full arduino boards there.

On the other hand I have installed the arduino library in proteus on my laptop and I found it running smoothly.

Tell me what I am missing in my desktop. Is there anything else required to use arduino in proteus that might be missing in proteus in my desktop.

I shall be thankful for all serious answers !

also for your kind information , I have copied the .lib and .idx files of arduino into the exact folder of proteus and I am guessing problem is somewhere else.

Why no one wanted to reply this issues

Maybe because this is an Arduino forum and not a Proteus forum.

Chances that people here have knowledge of Proteus are pretty slim.

see this link

I dont have library folder, when i install proteus 7. Where do i add arduino nano library. At solution for proteus 7 is given but when i installed proteus 7 it does not have library folder.

I had the same problem. I solved it by copying the libraries in the folder "C:\ProgramData\Labcenter Electronics\Proteus 8 Professional\LIBRARY".
Indeed, in the version of the Proteus software that I use, it is the default repertoire of libraries.

Hi: If someone still has problems with arduino libraries that do not appear in proteus, you have to copy them to the .. \ Proteus 8 Professional \ DATA \ LIBRARY folder, NOT to .. \ Proteus 8 Professional \ LIBRARY.

3 Likes

eeaahmad:
Hi Guys!

I am stuck in a problem that I am going to install the arduino library in proteus in my desktop to simply simulate this platform in proteus design suite 8. Unfortunately, when I search in proteus I cannot see the full arduino boards there.

On the other hand I have installed the arduino library in proteus on my laptop and I found it running smoothly.

Tell me what I am missing in my desktop. Is there anything else required to use arduino in proteus that might be missing in proteus in my desktop.

I shall be thankful for all serious answers !

hi dear i had the same problem , just copy your arduino library and paste in this destination
(C:\Program Files (x86)\Labcenter Electronics\Proteus 8 Professional\BIN)
now all arduino boards will be show.

Two comments here.

  • Windows UAC File and Registry Virtualization can, depending on settings, cause wacky behavior with files in protected locations (like program files), where depending on what privilege level a process is running as, different files or file contents will be seen (ie, a process run as admin will see different files, or different file contents than a process running without admin privileges). Particularly on Vista, where this was buggier, situations that should be impossible can occur. I have not a clue if this is relevant here, and this may be a total red herring, but whenever I have a program where I have to change things inside it's installation folder, I install it outside of program files to rule out this madness.

  • Proteus is garbage. As far as I am aware, basically anything that claims to simulate the behavior of a microcontroller (ie, including what the code does) is garbage. We often get people posting about a problem that turns up in a proteus simulation which, when running on the actual hardware, doesn't occur - the simulation does not reflect reality. There is really no substitute for prototyping your design and testing it there - I am of the opinion that proteus is a waste of time. A simulator that doesn't produce accurate results sends you wasting time chasing problems that exist only in simulations, and does not provide assurance that your design works.

You are truly a life saver.