Arduino Leonardo unable to find drivers

Hi,

I have an Arduino Leonardo, bought from RS electronics, and when I plug it in, it shows up as 'ATm32U4DFU' under 'Other devices' in Device Manager. I've tried Update Drivers with the 'C:\arduino\arduino-1.5.5\drivers' IDE folder, and with the 1.0.3 folder, and with the 1.0.1 folder, but nothing... I unzipped 'Old_Arduino_Drivers' and it doesn't find it in there either.

I ran 'dpinst-amd64.exe', those drivers installed successfully, but it doesn't show anything different under Device Manager.

In the IDE, the 'Ports' is greyed out, and it can't find the Leonardo in any of my USB ports.

Any idea what to do??

Regards Daniel

Is it possibly to use USB 3.0 if yes try USB 2.0 ( i was the same problem, i use arduino 1.0.5)

I have 3 USB 2.0 ports and 1 USB 3.0 port. It doesn't matter which one I plug it into. Still comes up as ATm32U4DFU and won't install drivers from the /drivers directory

I was looking in internet and i found this

http://embeddedmicro.com/tutorials/mojo/updating-the-mojo/

I hope this can solve you're problem.

What version of windows do you use ?

That looked good... but i think my Leonardo is broken now :(

I did all the instructions until the very last one, click 'Start Application' and then it says: com.atmel.flip.IspException Could not write to USB device.

So now it shows up in Device Manager under 'Atmel USB Devices' as ATmega32U4. But the Arduino IDE still has "Serial Port" greyed out, and says "Couldn't find a Leonardo on the selected port. " etc.

If you can see in Device manager then it is still alive :)

Are you choose the com port from the arduino ide ?

The bottom right of the IDE says "Arduino Leonardo on COM4", but Tools->Serial Port is greyed out and I can't select a port.

I've tried all 4 of my USB ports, but none of them work.

I will check mine when i return in my home but i thing Leonard use 2 ports one for upload the code and one for Serial monitor

I got a screen shot and i create drivers with libusb-win32

I hope this files to help you. :slight_smile:

Ard Leonardo.rar (534 KB)

hhdspmc64.sys (38.5 KB)

usbser.sys (32.5 KB)

Thanks for the help, but unfortunately I’m not getting any closer.

If I get rid of all the drivers, the setup looks like ATm32U4DFU.png

It won’t find any drivers in the folders you listed.

If I run the dpinst-amd64 program in arduino-1.5.5/drivers, it installs some files but doesn’t change anything.

If I use the “C:\Program Files (x86)\Atmel\Flip 3.4.7\usb” folder, it installs the device as shown in atmel.png

If I run the Flip program, it turns into an “Unknown USB device”, as in unknown.png

Now that’s how it’s stuck.

I’m new to all of this, so take this comment with a grain of salt.

I’ve been fighting with my uno for over a week now with this same issue. What seems to be working for me now is to unplug the usb from the computer. Then in device manager right click on Ports (Com & LPT). That brings up a menu that says “scan for hardware changes” or “properties” Then, before I select Scan for hardware changes, I hold down the reset button of the Uno and plug it back in. Then I hit scan and let the reset button go. So far it’s worked twice. Far from a proven method, but after hours and hours of trying everything ever suggested for every arduino thats ever existed, this is the only thing that’s worked for me even once. It still doesn’t clear my "Serial port COM3 already in use error, but I have a mallet here that I think might do the trick.

Best of luck to you.

Strange ...

Did you try to use the Arduino IDE V1.0.5 and choose this drivers ?

Also try to use this http://sourceforge.net/apps/trac/libusb-win32/wiki here is the download http://sourceforge.net/projects/libusb-win32/files/ it is the wizard to create drivers ;)

Good Luck :)