Arduino MEGA 2560, ERROR for compiling

today after update boards and library I'm not more able to Verify or upload a board?

following ERROR message:

Arduino: 1.8.10 (Mac OS X), Board: "Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)"

Error compiling for board Arduino Mega or Mega 2560.

Board Info:

BN: Arduino Mega or Mega 2560
VID: 0x2341
PID: 0x0042
SN: 55838323735351B0F042

I can not understand this issue, nothings has changed in between

thanks for a advice

regards Max

Please do this:

  • When you encounter an error, you’ll see a button on the right side of the orange bar “Copy error messages” in the Arduino IDE (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button…
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply.
  • Press “Ctrl + V”. This will paste the error between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.

If the text exceeds the forum’s 9000 character limit, save it to a .txt file and post it as an attachment. If you click the “Reply” button here, you will see an “Attachments and other settings” link.

sorry about the break

please see the attachment

the IDLE is 1.8.10

ERROR compiling MEGA 2560.txt (9.84 KB)

This is a bug in Arduino IDE 1.8.10. Please use Arduino IDE 1.8.9 until Arduino IDE 1.8.11 is released. You can download Arduino IDE 1.8.9 here:
https://www.arduino.cc/en/Main/OldSoftwareReleases#previous

it doe's not work with 1.8.9! ???

last Sunday I have updated the sketch and uploaded to the Mega without any problems!

(new date 2019 ---> 2020???)

Do you get the same error output with 1.8.9?:

panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0x1440824]

yes, the same error

ERROR compiling MEGA 2560_2.txt (40.9 KB)

the serial-monitor is normal running with this constellation

erase all files (Arduino IDE incl library) and new setup?

maxmueller50:
yes, the same error

No. They are different errors. The error when you were using Arduino IDE 1.8.10:

panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0x1440824]

The error when you are using Arduino IDE 1.8.9:

fork/exec /Applications/Arduino.app/Contents/Java/tools-builder/ctags/5.8-arduino11/ctags: bad CPU type in executable

Completely different errors, with completely different causes.

Try using the hourly build of the Arduino IDE:

thank you for this info - it works promptly with this 1.8.11 hourly build 2019/12/30

but what is the causes about this matter, the last board- and libraries update??? something else doesn't changed!

The error with Arduino IDE 1.8.9 was caused by one of the IDE's tools being 32 bit. macOS Catalina does not support 32 bit applications (previous macOS versions did).

The error with Arduino IDE 1.8.10 was caused by a bug in the arduino-cli tool. Arduino made the switch in Arduino IDE 1.8.10 to using arduino-cli and it caused some bugs. The bug that was affecting you has already been fixed, and this is why you can use the hourly build without errors.

So no, neither of these errors have anything to do with the board and library updates. It's all about the IDE.

thank you very much for this information's

unfortunately with this solution, every time by open the IDE, I have to give a special allowance by the macOS security, may by IDE 1.8.11 must be normal again, I think

Is it this problem?

first, by the installation YES

now to restart I have to allow in system-control / Security to set "every App's" and then it start

That's unfortunate. I'm sure this will be resolved in the Arduino IDE 1.8.11 production release. Hopefully it won't be too long before that comes.

can you give me some of advice to resolve my "old" IDE problem

I'm not able to work with them, every time 100'000 klick "allow access to ..." are necessary by all of operation (open the IDE, open a sketch, update, verifying ...

it is really impossible!!! :frowning: :frowning: :frowning: